Bluetooth für das neue Telefon

closeDieser Artikel wurde vor 9 Jahren 6 Monaten 29 Tagen veröffentlicht. Die Informationen in diesem Artikel sind möglicherweise veraltet. Bitte benutze die Suche oder das Archiv, um nach neueren Informationen zu diesem Thema zu suchen.

Gigaset SX685 isdn
Das Siemens Gigaset SX685 isdn auf meinem Schreibtisch, zwischen Desktop-Speaker und Notebook
Ich habe mir letzte Woche eine neues Telefon für’s Festnetz gegönnt, und zwar ein Siemens “Gigaset SX685 isdn“. Das ist eins mit ohne Kabel, welches auch den Standard “ECO-DECT” beherrscht. Im Vergleich zum “normalen” DECT-Standard wird hier die Funkleistung in Abhängigkeit des Abstandes zur Basisstation verringert. Steht das Telefon in der Basis, wird die Funkleistung wohl fast auf 0 gefahren.

Ein nettes Gimmick ist die Möglichkeit, den max. 250 Telefonbucheinträgen ein Bild zuzuordnen, welches dann bei einem Anruf im Display angezeigt wird. Um die Bilder auf das Telefon zu bekommen, verfügt da Gerät über eine Bluetooth-Schnittstelle. Da habe ich doch zunächst mal versucht, die Photos vom Handy aus zum Telefon zu kopieren. Das schlug wegen eines falschen Formates fehl: Das Gigaset versteht nur .bmp, auf dem Handy liegen die als .jpg. Zudem sind die Bilder auf dem Handy zu groß. Aber auch am PC verkleinerte und konvertierte Bilder ließen sich nicht übertragen, also muss ich die Übertragung mal direkt vom PC versuchen… O.o

Ich sprach mit einem Arbeitskollegen darüber, und der gab mir ein Bluetooth-USB-Dongle, welches er nicht benötigt. Ich sage auf diesem Weg noch mal Danke

Es handelt sich um ein “No-Name”-Produkt, was aber zunächst mal egal ist. Ich steckte das Teil an den PC, und eine grüne LED an diesem Dongle begann zu blinken. Wunderbar, dachte ich, war es das schon? Weit gefehlt. Ich musste zunächst noch mal einiges an Bluetooth-Komponenten nachinstallieren, aber ich sollte keine Verbindung aufbauen können. Sowohl vom Handy, als auch vom Gigaset aus habe ich mit einer Suche das Dongle zwar gefunden, konnte aber keines der Geräte damit paaren. Auch KBluetooth, welches ein Icon im der Kontrollleiste anzeigt, wollte keinen Adapter gefunden haben… :evil:

Jetzt ging die Fehlersuche los. Ich habe zunächst mal nachgesehen, wie sich das Dongle zu erkennen gibt:

markus@cowboy:~$ lsusb
Bus 001 Device 005: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
markus@cowboy:~$

(Bei der Ausgabe habe die Identifikationen der anderen USB-Geräte entfernt )

Die Abfrage hciconfig -a ergab dann:

hci0:   Type: USB
        BD Address: 00:00:00:00:00:00 ACL MTU: 0:0 SCO MTU: 0:0
        DOWN
        RX bytes:0 acl:0 sco:0 events:0 errors:0
        TX bytes:0 acl:0 sco:0 commands:0 errors:0

Worauf ich den Befehl hciconfig hci0 up ausführte und obige Abfrage erneut machte:

hci0:   Type: USB
        BD Address: 00:10:60:A9:BD:67 ACL MTU: 192:8 SCO MTU: 64:8
        UP RUNNING
        RX bytes:348 acl:0 sco:0 events:11 errors:0
        TX bytes:35 acl:0 sco:0 commands:10 errors:0
        Features: 0xff 0xff 0x0f 0x00 0x00 0x00 0x00 0x00
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy:
        Link mode: SLAVE ACCEPT
        Name: 'James-1711����'
        Class: 0x000000
        Service Classes: Unspecified
        Device Class: Miscellaneous,
        HCI Ver: 1.1 (0x1) HCI Rev: 0x460 LMP Ver: 1.1 (0x1) LMP Subver: 0x460
        Manufacturer: Cambridge Silicon Radio (10)

Die Kernel-Module waren auch geladen, wie lsmod | grep hci ergab:

hci_usb                19996  0
bluetooth              63844  3 rfcomm,l2cap,hci_usb
firewire_ohci          23040  0
firewire_core          47808  1 firewire_ohci
ehci_hcd               41868  0
ohci_hcd               31492  0
usbcore               154608  9 snd_usb_audio,snd_usb_lib,hci_usb,uvcvideo,usb_storage,usblp,ehci_hcd,ohci_hcd
ssb                    39812  1 ohci_hcd

Ich habe dann auf der Konsole noch mal nach cat /proc/bus/usb/devices gefragt, und er relevante Teil der Ausgabe war dieses:

T:  Bus=01 Lev=02 Prnt=04 Port=00 Cnt=01 Dev#=  8 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=e0(unk. ) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=0a12 ProdID=0001 Rev=11.20
C:* #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=  0mA
I:* If#= 0 Alt= 0 #EPs= 3 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=1ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 2 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=03(O) Atr=01(Isoc) MxPS=   0 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=   0 Ivl=1ms
I:  If#= 1 Alt= 1 #EPs= 2 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=03(O) Atr=01(Isoc) MxPS=   9 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=   9 Ivl=1ms
I:* If#= 1 Alt= 2 #EPs= 2 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=03(O) Atr=01(Isoc) MxPS=  17 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=  17 Ivl=1ms
I:  If#= 1 Alt= 3 #EPs= 2 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=03(O) Atr=01(Isoc) MxPS=  25 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=  25 Ivl=1ms
I:  If#= 1 Alt= 4 #EPs= 2 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=03(O) Atr=01(Isoc) MxPS=  33 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=  33 Ivl=1ms
I:  If#= 1 Alt= 5 #EPs= 2 Cls=e0(unk. ) Sub=01 Prot=01 Driver=hci_usb
E:  Ad=03(O) Atr=01(Isoc) MxPS=  49 Ivl=1ms
E:  Ad=83(I) Atr=01(Isoc) MxPS=  49 Ivl=1ms

Das ganze habe ich dann mal im Sidux-Forum hinterfragt, und eine einzige Antwort stieß mich auf die Lösung, die eigentlich einfacher nicht hätte sein können: Den Bluetooth-Dienst neu starten:

root@cowboy:$ /ect/init.d/bluetooth restart

Ab sofort konnte ich sowohl Handy, als auch das Gigaset mit dem Dongle paaren und Daten austauschen. Nur die Übertragung der Bilder auf das Gigaset geht noch immer nicht. Dafür braucht man scheinbar eine Siemens-Software, die man zwar kostenlos downloaden kann, die es aber nur für die WinDOSe gibt.

3 Antworten auf „Bluetooth für das neue Telefon“

  1. Hi,

    ich besitze auch ein SX685 und würde gern unter Linux Daten damit austauschen. Das Pairing klappt auch über das Bluetooth Applet von Gnome, allerdings kann ich keine Daten austauschen.

    Die “Browse Device”-Funktion klappt mit meinem SX685 nicht. Wie genau tauschst du die Daten, insbesondere Telefonbucheinträge aus?

    Danke & Grüße

    Ronny

  2. @Ronny: Sorry, dass ich mich erst jetzt melde. War ein wenig im Stress.

    Ich habe es bisher auch noch nicht bewerkstelligen können, mit dem Siemens Daten auszutauschen. Das klappte bisher nur mit dem Motorola-Handy Razr V3i.

    Das Siemens benötigt wohl wirklich die herstellereigene Software. Ich habe einige Fotos bei einem Kollegen auf das Gerät geladen. Aber der Speicherplatz ist derart begrenzt, dass es sich nicht weiter lohnt…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

This Blog will give regular Commentators DoFollow Status. Implemented from IT Blögg