Leyenfilter

#!/usr/bin/perl
# Leyenfilter 2.0 – (c) 2009 by Ursula
use Ursula::Leyenfilter;
# Ursulas Liste
my %URSULA_SPERRLISTE = getSperrListe(„O:/USBStick-Ursula/sperrliste.xls“) or die „Uschi, du hast vergessen deinen USB-Stick einzustecken! (Das Stecker-Ding kommt in den Rechner)“;

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
#!/usr/bin/perl
#
# Leyenfilter 2.0 - (c) 2009 by Ursula
#
 
use Ursula::Leyenfilter;
 
# Ursulas Liste
my %URSULA_SPERRLISTE 	= getSperrListe("O:/USBStick-Ursula/sperrliste.xls") or die "Uschi, du hast vergessen deinen USB-Stick einzustecken! (Das Stecker-Ding kommt in den Rechner)";
 
# Liste des BKA
my %BKA_SPERRLISTE 	= getSperrListe('ftp://uschi:apfel1@ftp.bka.de/bka_sperrliste.xls');
 
# Provider die nicht unterschrieben haben
my %BADISP_SPERRLISTE 	= ("www.einsundeins.de" => 'Grund: Kinderschaender!');
 
 
 
Ursula::Leyenfilter->run(\&process_packet);
 
sub process_packet {
        my($user_data, $header, $packet) = @_;
 
 
	if ($header->{'HTTP_URI'} =~ /(child|kinder).*(porn|pornografie|xxx|erotic|peepshow|nude|naked)/ or
	    defined($URSULA_SPERRLISTE{$header->{'HTTP_URI'}) or
	    defined($BKA_SPERRLISTE{$header->{'HTTP_URI'}) or
	    defined($BADISP_SPERRLISTE{$header->{'HTTP_URI'})
	# Notiz: Gesetze noch nicht verabschiedet, kommt noch.
	# $header->{'HTTP_URI'} =~ /thepiratebay.org/ or
	# $header->{'HTTP_URI'} =~ /wikipedia.org/ or
	# $header->{'HTTP_URI'} =~ /www.amnesty.de/ or
	# $header->{'HTTP_URI'} =~ /www.wikileaks.de/ or
 
	# Erst kurz vor den Wahlen auskommentieren
	# $header->{'HTTP_URI'} =~ /spd.de/ or
	# $header->{'HTTP_URI'} =~ /gruene.de/ or
	   )
	{
 
		$packet->redirect('http://www.bka.de/dukommsthiernichtrein.html');	
 
	}
 
 
 
 
}
 
 
 
# 3291215ca7428d66f7c5623def10fc09

[via]

Zeit dass sich was dreht…

Ich komme zur Zeit gar nicht mehr dazu, hier was zu schreiben. Seit dem ich den neuen PC hier stehen habe, läuft nichts mehr so, wie es soll. Ich habe inzwischen wieder Sidux am laufen, allerdings die 32Bit-Version. Die PC-Komponenten an sich funktionieren auch ohne Probleme.

Ich komme zur Zeit gar nicht mehr dazu, hier was zu schreiben. Seit dem ich den neuen PC hier stehen habe, läuft nichts mehr so, wie es soll.

Ich habe inzwischen wieder Sidux am laufen, allerdings die 32Bit-Version. Die PC-Komponenten an sich funktionieren auch ohne Probleme.

Ich hatte den PC von der Sidux-DVD gebootet, und das komplette System von der alten auf die neue Festplatte kopiert. Anschließend noch die /boot/grub/menu.list und die /etc/fstab an die neuen Pfade angepasst, und gut.

Im Großen und Ganzen klappt das hier ganz gut. Icedove läuft mit den alten Einstellungen, und die Mails sind auch noch alle da. Iceweael hatte ja eh ein Problem mit den Schriftgrößen, und ich hatte den original Firefox laufen. Der läuft jetzt auch wieder, mit allen Einstellungen. Sogar die durch den plötzlichen Tod des alten PC abgebrochene Session wurde beim ersten Start wieder hergestellt.

Mich wundert nur, dass der Netzwerk.Anschluss als eth1 läuft, und eth0 existiert nicht. Zudem musste ich die Netzwerk-Einstellungen neu setzen. Aber vorher war auch eth0 aktiv, und durch den Device-Wechsel musste ich dem neuen Anschluss wohl die Einstellungen neu zuweisen.

Ein Problem habe ich mit meinem Multifunktions-Drucker… So kann ich zwar drucken, wie gehabt, aber nicht scannen. CUPS läuft ohne Probleme, aber Sane mag irgendwie nicht. Wenn ich X-Sane starte, knn ich den Scanner auswählen, und bekomme dann eine Fehlermeldung, die zum Abbruch des Programmes führt:

Sane-Fehlermeldung
Die Fehlermeldung von Sane

Wenn ich Kooka starte, kann ich ebenfalls den Scanner auswählen, und das Programm startet dann auch. Nur findet sich eine Fehlermeldung in dem Bereich, wo ich eigentlich die Einstellungen für den Scanner bzw. den Scanvorgang mache:

Kooka-Fehlermeldung
Das Kooka-Fenster mit der Fehlermeldung

Ich muss dazu sagen, dass ich es als normaler User versuche, aber die udev-Regeln sind entsprechend gesetzt. Aber auch als root bekomme ich diese Fehlermeldungen. Ich habe alles, was Sane heißt, neu installiert, aber ich habe damit keinen Erfolg gehabt.

Hier liegt auch noch so einiges andere im Argen, was aber im Moment nicht so wichtig ist. Aber das mit dem Scanner ärgert mich…