Fehlersuche am Eee-PC

closeDieser Artikel wurde vor 8 Jahren 7 Monaten 5 Tagen veröffentlicht. Die Informationen in diesem Artikel sind möglicherweise veraltet. Bitte benutze die Suche oder das Archiv, um nach neueren Informationen zu diesem Thema zu suchen.

Inzwischen habe ich mal ein bisschen Ursachenforschung betrieben, was die fehlende Netzwerk-Unterstützung auf dem Netbook angeht. Netbook… Ohne Netzwerk… na das geht ja mal gar nicht…

Ich habe nochmal die Live-CD gebootet, und dann aus dem Terminal heraus ein paar Befehle abgesetzt und die Ausgaben in Text-Dateien umgeleitet, die ich per USB-Stick auf den Desktop transportieren konnte.

Also zunächst mal diese hier:

ubuntu@ubuntu:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
01:00.0 Ethernet controller: Attansic Technology Corp. Device 1062 (rev c0)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
ubuntu@ubuntu:~$

Wie man sieht, werden die Netzwerk-Controller erkannt (die beiden letzten Einträge), allerdings nicht aktiviert. Also gehts weiter, so wie es bei ubuntuusers.de beschrieben ist:

ubuntu@ubuntu:~$ egrep -v "^$|1#" /etc/network/interfaces
auto lo
iface lo inet loopback
ubuntu@unbuntu:~$ egrep -v "^$|1#" /etc/resolv.conf
egrep: /etc/resolv.conf: No such file or directory
ubuntu@unbuntu:~$ egrep -v "^$|1#" /etc/hosts
127.0.0.1 localhost
127.0.1.1 ubuntu
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
ubuntu@unbuntu:~$

Wie ich schon angesprochen hab: es wird nur das lokale Loop-Device erkannt. Eine weitere Einrichtung der der Dateien resolv.conf und hosts habe mir bisher natürlich verkniffen, daher wird die eine Datei nicht gefunden, und die andere kennt nur den lokalen Computer.

Dass nur das lokale Loopback Device gefunden wird, bestätigt denn auch die Ausgabe von ifconfig:

ubuntu@ubuntu:~$ ifconfig
lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
ubuntu@ubuntu:~$ route -n
Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
ubuntu@ubuntu:~$ iwconfig
lo        no wireless extensions.
 
pan0      no wireless extensions.
 
ubuntu@ubuntu:~$

Klar, keine Routen, hab ja auch noch nichts eingerichtet.

Ich hab dann noch mal die Liste der geladenen Module:

ubuntu@ubuntu:~$ lsmod
Module                  Size  Used by
binfmt_misc            16776  1 
i915                   65540  2 
drm                    96296  3 i915
ppdev                  15620  0 
lp                     17156  0 
parport                42220  2 ppdev,lp
bridge                 56340  0 
stp                    10500  1 bridge
bnep                   20224  2 
input_polldev          11912  0 
joydev                 18368  0 
snd_hda_intel         435636  3 
snd_pcm_oss            46336  0 
snd_mixer_oss          22656  1 snd_pcm_oss
snd_pcm                82948  2 snd_hda_intel,snd_pcm_oss
snd_seq_dummy          10756  0 
snd_seq_oss            37760  0 
snd_seq_midi           14336  0 
snd_rawmidi            29696  1 snd_seq_midi
snd_seq_midi_event     15104  2 snd_seq_oss,snd_seq_midi
snd_seq                56880  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29704  2 snd_pcm,snd_seq
snd_seq_device         14988  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
uvcvideo               63240  0 
iTCO_wdt               19108  0 
compat_ioctl32          9344  1 uvcvideo
psmouse                61972  0 
iTCO_vendor_support    11652  1 iTCO_wdt
intel_agp              34108  1 
snd                    62628  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
pcspkr                 10496  0 
serio_raw              13316  0 
soundcore              15200  1 snd
videodev               41600  1 uvcvideo
agpgart                42696  3 drm,intel_agp
snd_page_alloc         16904  2 snd_hda_intel,snd_pcm
v4l1_compat            21764  2 uvcvideo,videodev
video                  25360  0 
output                 11008  1 video
eeepc_laptop           18452  0 
squashfs               46344  1 
aufs                  165924  1 
exportfs               12544  1 aufs
isofs                  39844  1 
nls_iso8859_1          12032  1 
nls_cp437              13696  2 
vfat                   18816  1 
fat                    58272  1 vfat
usb_storage            82880  2 
fbcon                  46112  0 
tileblit               10752  1 fbcon
font                   16384  1 fbcon
bitblit                13824  1 fbcon
softcursor              9984  1 bitblit
ubuntu@ubuntu:~$

Und die Kernelmeldungen zu den bekanntesten Chipsätzen:

ubuntu@ubuntu:~$ dmesg | egrep 'net|eth|sky|sis|via|3c3|3c5|e100|8139|8169|acx|air|ath|atme'
[    0.648315] net_namespace: 776 bytes
[    1.808213] audit: initializing netlink socket (disabled)
[    2.495609] Driver 'sd' needs updating - please use bus_type methods
[    2.495630] Driver 'sr' needs updating - please use bus_type methods
[    3.204805] device-mapper: multipath: version 1.0.5 loaded
[    3.204812] device-mapper: multipath round-robin: version 1.0.0 loaded
[   87.924083] eeepc: Get control methods supported: 0x101711
[  104.071313] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[  823.717925] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.EBTS] (Node f6c150f0), AE_TIME
[  823.718032] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.SBRG.EC0_.UBCS] (Node f6c19090), AE_TIME
[  823.718122] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.CBST] (Node f6c19210), AE_TIME
[  823.718211] ACPI Error (psparse-0524): Method parse/execution failed [\_SB_.PCI0.BAT0._BST] (Node f6c19150), AE_TIME
ubuntu@ubuntu:~$

Irgendwie hilft mir das nicht wirklich weiter… Kann sonst wer was mit dem ganzen Zeugs was anfangen?

4 Antworten auf „Fehlersuche am Eee-PC“

  1. Ich kann dir da jetzt nicht wirklich weiterhelfen… :|
    Und sicher hast du auch mehr Ahnung von Linux als ich.
    Aber als ich hier mein erstes OpenSuse (10.2) installierte hatte ich ähnliche Probleme. Ich habe dann verzweifelt und mir erstmal wieder ein Windows besorgt.
    Dann kam die Version 11.0 und da ging es ohne Probleme !
    Warum nimmst du nicht das für den Kleinen optimierte Xandros ? Damit funktioniert ALLES !
    Oder gibt es das bei deinem Modell nicht mehr ?

  2. @Gucky: Ich bin kein Freund von Xandros, auch nicht von Suse. Ich hab zwar auch mal auf Suse gelernt, aber seit dem Novell-Deal mit Winzigweich ist diese Version für mich obsolet…

    Ob es die Xandrosversion noch für den aktuellen Eee-PC gibt, weiß ich nicht. aber selbst die angepasste Ubuntu-Version bekomme ich nicht ans laufen. Aktuell habe ich ne Live-CD mit Kununtu gestartet, wegen KDE, aber unter der Haube ists das gleiche wie Ubuntu…

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

This Blog will give regular Commentators DoFollow Status. Implemented from IT Blögg