Kein Adobe Air unter Unity?

Nachdem ich die Tage Ubuntu neu installiert hab, hadere ich schon wieder damit. Ich bekomme meinen Lieblings-Twitter-Client TweetDeck nicht installiert, weil sich dass dafür benötigte Air-Framework von Adobe unter Unity nicht installieren lässt…

TweetDeck-Logo altNachdem ich die Tage Ubuntu neu installiert habe, hadere ich schon wieder damit. Ich bekomme meinen Lieblings-Twitter-Client TweetDeck nicht installiert, weil sich dass dafür benötigte Air-Framework von Adobe unter Unity nicht installieren lässt…

Adobe pflegt Air für Linux bekanntlich nicht mehr, ich habe hier die Installationsdatei der letzten Version. Die hat unter KDE noch einwandfrei funktioniert, und somit konnte ich auch TweetDeck installieren. Auch die letzte Version, die im Air-Framework lief, bevor TweetDeck von Twitter gekauft wurde. Die alte Version unterstützt nämlich auch Identi.ca, nie aktuelle nicht. Zudem läuft die aktuelle Version unter Linux nur als Webapp, z.B. als Chrome-Plugin.

Air meckert bei der Installation das Fehlen des Gnome Keyring oder der KDE-Wallet an, beides Passwortmanager für die entsprechenden Desktopumgebungen. Der Gnome Keyring war jedoch installiert, KDE-Wallet habe ich extra nachinstalliert, und trotzdem wird das Fehlen angemeckert und die Installation von Air bricht mit einer entsprechenden Fehlermeldung an.

Die Suche nach einem gescheiten Client für Twitter und Identi.ca bin ich auf Turpial gestoßen. Den Kommentaren im Ubuntu Software-Center nach soll das wohl der beste Twitter-Client für Linux sein. Allerdings ist das nach einem ersten Test nicht multiaccountfähig, so dass ich mich für einen Account entscheiden müsste…

Damit stehe ich wieder einmal vor der Frage, welchen Twitter-Client ich benutzen soll. Anforderungen: Multiaccount, Mehrspaltenansicht, und vor allem alle Accounts gleichzeitig im Blick, ohne Umschalten oder so. So, wie es TweetDeck macht. Das alte TweetDeck natürlich, wegen Identi.ca…

Ich habs getan…

Ich habe meinen Laptop heute neu aufgesetzt und Ubuntu 12.04 installiert. Ich hätte natürlich auch einfach die nötigen Pakete nachinstallieren können, aber so habe ich erst mal wieder ein sauberes System.

Ich habe meinen Laptop heute neu aufgesetzt und Ubuntu 12.04 installiert. Ich hätte natürlich auch einfach die nötigen Pakete nachinstallieren können, aber so habe ich erst mal wieder ein sauberes System.

Gestern hab ich ja mein KDE-Problem beschrieben und die Nutzung von Unity in Erwägung gezogen. Nachdem mir dann in den Kommentaren der Befehl xkill vorgestellt wurde, den ich bis dato tatsächlich noch nicht kannte, und heute nach dem Systemstart wieder einen leeren Desktop hatte, hatte ich die Schnauze voll. USB-Stick rein und Neustart, mit [F9] die Bootreihenfolge geändert, und Ubuntu mit Unity-Oberfläche installiert.

Da meine Daten auf einer separaten Partition liegen, hatte ich da keinen Verlust zu erwarten. Einzig die ganzen versteckten Verzeichnisse mit den Konfigurationen der Anwendungen habe ich weitgehend manuell gelöscht.

Jetzt gehts an die Einrichtung des Systems und das Nachinstallieren diverser Software aus externen Quellen, z.B. Skype oder den Browser Opera. Und dann mal schauen, ob mir Unity wirklich so gut gefällt, wie es nach den ersten Gehversuchen den Anschein hat. Ich halte Euch auf dem Laufenden.

Irgendwas stimmt hier nicht…

Ich nutze auf meinem Laptop, einem HP Pavilion dv7, Kubuntu 12.04 („Precise Pangolin”) ein. Es handelt sich um eine LTS-Version mit Support bis ins Jahr 2017. Mit der aktuellen Version 12.10 hatte ich Probleme bei der Unterstützung des Grafik-Chips, zudem stand sie anfangs wegen Amazon-Links in Suchergebnissen in der Kritik.

Ich nutze auf meinem Laptop, einem HP Pavilion dv7, Kubuntu 12.04 („Precise Pangolin”) ein. Es handelt sich um eine LTS-Version mit Support bis ins Jahr 2017. Mit der aktuellen Version 12.10 hatte ich Probleme bei der Unterstützung des Grafik-Chips, zudem stand sie anfangs wegen Amazon-Links in Suchergebnissen in der Kritik.

Nun, ich bin mit Precise soweit zufrieden und werde auch von der Aktualisierung auf höhere Versionen absehen. Softwareaktualisierungen kommen ja auch so, mit steht also trotzdem ein recht aktuelles System zur Verfügung. Allerdings habe ich seit ein paar Tagen Probleme…

Da gab es nämlich wieder mal einen Schwung Updates, u.A. für den X-Server, und dabei ist wohl irgendwas schief gelaufen. Den KDE-Desktop betreibe ich in der Ordneransicht und habe so einige Icons auf dem Desktop abgelegt. Ist noch ein Relikt aus alten Windoof-Tagen…

Desktop Kontextmenu
In den Einstellungen der Ordner-Ansicht kann ich die Icons zurückholen
Seit dem Update nun ist der Desktop nach dem Systemstart oft (nicht immer, das ist ja das Eigenartige) leer, dafür gibts am rechten Bildschirmrand einen vertikalen Scrollbar. Der hat zwar nur wenige Pixel Spielraum, aber er ist halt da. Wenn ich dann mit Rechts auf den Desktop klicke und im Kontext-Menü Enstellungen für „Ordner-Ansicht” auswähle, dann kann ich eine andere Ansicht wählen, anwenden, und dann wieder auf Ordner-Ansicht zurückschalten. Dann sind alle Symbole wieder da, allerdings am linken Bildschirmrand alphabetisch sortiert. Meine Anordnung muss ich dann manuell wieder herstellen.

Das schwierige daran ist ja nun, dass der Fehler eben nicht immer auftritt. Allerdings nach den meisten Systemstarts. Dann mag auch mal gerne zwei-, dreimal in Folge alles in Ordnung zu sein, um beim vierten Start wieder einen leeren Desktop zu präsentieren.

Langsam trage ich mich mit dem Gedanken, KDE den Rücken zu kehren. Ich habe mir bei mehreren Bekannten diese Unity-Oberfläche mal etwas genauer angesehen, und irgendwie gefällt mir das. Auch wenn es sicherlich nicht der Weisheit letzter Schluss ist, aktuell scheint es zumindest besser als KDE zu sein. Ich habe hier einen USB-Stick mit Ubuntu Live-Image liegen und habe das hier auch schon getestet. Aber, und da ist mein Problem, gibt es unter KDE Funktionen z.B. zum Abschießen von hängenden Programmen, die mir unter anderen Desktopumgebungen fehlen. So verwandelt sich z.B. durch die Tastenkombination [Strg+Alt+Esc] der Mauszeiger in einen Totenkopf, der mit einem Klick auf ein nicht reagierendes Fenster die entsprechende Anwendung abschießt. Gerne genutzt von mir, aber Vergleichbares habe ich woanders noch nicht gefunden…

Was meint Ihr? Wie kann ich den Fehler unter KDE abstellen? Oder besser umsteigen? Und auf was?

Plugin erweitert

Ich setze hier für Emoticons (Smilies) das Plugin Font Empticons ein, welches diese schlichten Grinsezeichen in ebenso schlichte, grafische Grinser übersetzt. Und die haben den Vorteil, dass sie das Zeilenbild nicht zerstören, da sie sich auf Zeilenhöhe beschränken.

Ich setze hier für Emoticons (Smilies) das Plugin Font Emoticons ein, welches diese schlichten Grinsezeichen in ebenso schlichte, grafische Grinser übersetzt. Und die haben den Vorteil, dass sie das Zeilenbild nicht zerstören, da sie sich auf Zeilenhöhe beschränken.

Die einzige Unzulänglichkeit des Plugins, die mir aufgefallen ist: Es werden nur Emoticons in den Artikeln und in Seiten ersetzt, nicht aber in den Kommentaren. Nachdem ich mir die Datei font-emoticons.php genauer angesehen habe, war die Lösung recht einfach:

In dieser Datei findet sich ab Zeile 71 das Array mit den zu ersetzenden Zeichenfolgen, hier kann man möglicherweise auch noch andere Kürzel einsetzen. Direkt darunter, in Zeile 96 findet sich der Filter, der die Ersetzung in Posts und Pages erledigt:

96
add_filter('the_content', array($this, 'replace_emots'), 500);

Ich habe diese Zeile kopiert und unmittelbar darunter nochmal eingesetzt, dabei habe ich dann den angesprochenen Hook ersetzt, weil ich die Smilies ja in die Kommentare bringen will:

97
add_filter('comment_text', array($this, 'replace_emots'), 500);

Fertig. Mehr ist das nicht. Die geänderte Datei noch ins Plugin-Verzeichnis hochladen, dabei die Original-Datei überschreiben, und schon stehen die grafischen Smilies auch über dieses Plugin den Kommentaren zur Verfügung.

Netter Versuch…

Gestern erhielt ich gegen Mittag eine Mail, dass ich hier einen Kommentar moderieren soll. Schon, endlich mal wieder ein Ansporn zum Weiterbloggen, dachte ich so…

Gestern erhielt ich gegen Mittag eine Mail, dass ich hier einen Kommentar moderieren soll. Schon, endlich mal wieder ein Ansporn zum Weiterbloggen, dachte ich so…

Da ich zu der Zeit aber gerade unterwegs war und keine Lust hatte, die Moderation übers Smartphone vorzunehmen, habe ich erst am späten Abend ins Backend geschaut und wurde an den Kommentar erinnert. Aber was steht da? 2 Kommentare warten auf Moderation? Hmm, hab doch nur eine Mail bekommen…

Comment-Spam
Interessant, die beiden Kommentare

Schaut selbst: zuerst kam ein Kommentar, dessen Autor gleich Reklame für einen Online-Swingerclub machen wollte. Darüber bekam ich aber keine Mail, die ist wegen des angegeben URL vielleicht auch im Spamfilter gelandet und da von mir übersehen worden. Der zweite Kommentator, eine Minute später, gab keine Webseite an. Anderer Name, andere Mailadresse, unterschiedliche weil einmal eben keine Angabe zum URL. Also zwei verschiedene Kommentatoren, und der eine hat vom anderen abgeschrieben? :-?

Kann eigentlich nicht sein, denn beide Kommentare waren in der Moderation, und der Autor des zweiten Kommentars konnte den ersten ja gar nicht sehen, zumal beide Kommentare auch noch unter andere Artikel sollten. Aber dann fiel mir auf, dass beide Kommentare von ein und derselben IP-Adresse stammen.

Das war dann wohl der endgültige Beweis, dass beide Kommentare vom gleichen Autor stammen. Das veranlasste mich dann, beide Kommentare als Spam zu markieren. Wäre es nur der zweite Kommentar gewesen, hätte ich ihn sogar freigeschaltet, obwohl er unter den Weihnachtsgrüßen nicht wirklich gepasst hätte.

Eigentlich bin ich erstaunt, dass der erste Kommentar nicht schon wegen des URL im Spamfilter gelandet ist. Dann hätte ich es vermutlich auch nicht gemerkt, und den zweiten freigeschaltet…