Das war knapp…

Kinders ich sach euch, ich bin noch richtig ausse Puste… Ich habe mich heute, ähm gestern nachmittag an der Susi als root angemeldet, um die letzte NTFS-Partition mit ext3 zu formatieren und dann mein Home-Verzeichnis darauf zu kopiern. Für den Kopiervorgang darf ja nicht auf die Dateien zugegriffen werden, daher habe ich das als root gemacht. Die bisherige Home-Partition war ja verschlüsselt, das habe ich jetzt gelassen und kann sowohl von der Susi aus, als auch von Debian an meine Daten.

Die verschlüsselte Partition habe ich ebenfalls mit ext3 neu formatiert, um sie für eine frische Debian-Installation zu nutzen. Da habe ich nun gut 40 GB zur Verfügung, auf der alten Debian-Partition waren es nur 7 GB. Diese 7 GB habe ich an die /home-Partition angehängt. Da ich nun zwei Root-Systeme und Swap auf der zweiten Platte hatte, und die Daten auf der ersten, habe ich die Festplatten noch umgejumpert. Jetzt sind die Systeme auf Master, die Daten auf Slave.

Natürlich habe ich in der Susi die /etc/fstab angepasst, aber die /etc/cryptotab nicht gelöscht bzw. umbenannt. Dass ich mit dem Bootloader erst mal nicht weiterkomme, war klar. Deshalb habe ich eine Net-Install von Debian eingelegt, davon gebootet und Etch installiert. Die Routine wird die Susi schon finden und in Grub einbinden, war die Tage ja auch so. Pustekuchen, da fand sich nur Debian GNU/Linux im Bootlader, keine Susi.

Daher habe ich von der Suse-DVD gebootet, um von da aus das installierte System zu starten. Doch da hagelte es Fehlermeldungen ohne Ende und zum Schluss startete noch nicht mal der X-Server. Das Kernel-Modul für den nVidia-Treiber wurde nicht gefunden.

Nun fing ich an, Blut und Wasser zu schwitzen… Debian noch nicht eingerichtet, und die Susi zerschossen. Klasse, da kam eine Nacht auf mich zu. Ich habe erneut von der Suse-DVD gebootet, und dann das System repariert. Nur ließ sich Grub von der Suse aus nicht in den MBR schreiben, why ever. Nach der Reparatur hatte ich wieder nur Debian im Angebot.

Also habe ich Etch gestartet und die Einträge für die Susi von Hand gemacht. Dann konnte ich Suse wieder booten, aber durch den Eintrag in der cryptotab kam die Passwortabfrage. Nur wurde das Passwort nicht gefunden, und meine neue Home-Partition hat zufällig die gleiche Bezeichnung, wie die alte vor dem Umbau, nämlich hdb5, und natürlich den gleichen Mountpunkt. Daher kam ich nicht an meine Daten, musste erst als root die cryptotab in /etc umtaufen und neu booten. Dann ging es wieder, ich schreibe jetzt hier von Suse aus. Das System läuft wieder. Wo der Fehler war, weiß ich nicht. Aber ich habe mir fast die ganze Nacht um die Ohren gehauen, um das fertig zu kriegen und das noch eben schriftlich zu fixieren. Zwanzig nach vier ist es jetzt, Gute Nacht!

Auch die KDE 4 Live-CD will nicht

Naja, will schon, aber kann wohl nicht. Beim Booten kam die erste Fehlermeldung: Das System (Suse) war nicht in der Lage, mein Netzwerk via DHCP zu konfigurieren. Dann landete ich am KDE LogIn Screen… Rate mal mit R….. User “linux” war eingestellt, aber wie lautet das Passwort? Einfach mal “linux” eingegeben, und ich war drin in KDE 4.

Ich war enttäuscht. Das System schien meiner Grafikkarte nur 256 Farben zu entlocken, es sah grausig aus. Dann meldete sich auch schon der Crash-Manager, oder wie das schon aus KDE 3 bekannte Dingen heißt. Da war direkt die Lautstärke-Regelung abgestürzt. Dem KDE 4 Desktop war sowieso nicht ein Ton zu entlocken.

Der Konqueror ist zwar noch vorhanden, fungiert aber wohl nur noch als Web-Browser. Für den Einsatz als Dateimanager haben die Entwickler sich was Neues einfallen lassen. Ließ sich aber nicht starten, brach sofort mit einer Fehlermeldung ab. Genau wie die meisten anderen Programme auch, überwiegend sogar ohne Fehlermeldung.

Einzig Amarok konnte ich starten. Und ich sah Version 2! Scheint unübersichtlicher zu sein als die hier unter KDE 3 eingesetzte Version 1.4. Auf den ersten Blick zumindest. Testen konnte ich eh nicht (kein Sound), da meine Festplatten nicht eingebunden waren. Also hatte ich keinen Zugriff auf meine Musik. Und Internet-Radio? Wie war das doch gleich? Ach ja, kein Netzwerk. Und Yast startete nicht, sonst hätte ich versucht, Netz und Sound einzurichten und eine gescheite Farbwiedergabe zu erreichen.

Also war mein erster Kontakt mit KDE 4 ein Schlag ins Wasser. Ich werde wohl mal die zweite Beta abwarten und es dann noch mal versuchen. Hoffentlich klappt das ohne Investition in eine neue Grafikkarte. Gute und erschwingliche AGP-Karten sind rar, und PCIe hat mein Rechenknecht noch nicht.

KDE 4 will nicht so recht…

Nachdem ich nun gestern Abend bzw. heute früh KDE 4 installiert habe, bin ich erstmal enttäuscht. Version 4 ist neben Version 3 installiert, und am Anmelde-Bildschirm kann man die KDE-4-Session auswählen. Nur stürzt dann sofort der X-Server ab.

Ich nutze also weiter KDE 3 (3.5.7, um präziese zu sein), und werde morgen mal das inzwischen geladene Image einer KDE-4-Live-CD brennen und ausprobieren. Viel Hoffnung habe ich allerdings nicht…

Also bei KDE 4 soll der ganze 3D-Kram mit Beryl oder Compiz oder was auch immer per default aktiviert sein. Das kann die Ursache für mein Scheitern sein, denn meine Grafikkarte (GeForce FX5200 mit 128 MB RAM) macht das nicht mit. Allerdings bin ich davon ausgegangen, dass eine intelligente Software das automatisch erkennt und den Mist entsprechend abschaltet. Aber gut, es ist erst mal die erste Beta-Version von KDE 4. Kann ja noch was werden.

Ich will KDE 4!

Hallo,

soeben habe ich bei der Susi das KDE4-Repositority eingebunden, und werde nun mal schaun, was KDE Version 4 Neues bring. Ich mach das auf der Susi, weil ich hier eine Spielwiese habe. Gearbeitet wird künftig nur noch mit Debian Etch. Wenn ich tatsächlich KDE 4 am laufen habe, werde ich mal berichten

Umstieg auf Debian Etch

So Leute,

alles, was ich hier bisher geschrieben habe, bezog sich auf openSUSE 10.2. Da mit aber der Novell-Deal mit Winzigweich vom letzten November noch immer gegen den Strich geht, steige ich gerade von Suse auf Debian Etch um. Ich möchte keinen Windoof-PC mehr haben, auch sonst nix mehr mit Winzigweich zu tun haben. Und erst recht will ich kein Linux, welches durch Winzigweich-Lizenzen korrumpiert wird!

Bei Debian ist wirklich vom ersten bis zum letzen Bit alles OpenSource. Und das wird auch so bleiben. Dazu ist Debian deutlich stabiler im Betrieb, als die Susi es je sein wird. Das liegt an den langen Versions-Zyklen von ca. 18 Monaten. Die nächste Version wird lange getestet, bevor sie als “stable” zu den Usern kommt. Als Nachteil könnte man dabei sehen, dass die eingesetzte Software veraltet ist. Denn außer Security-Patches gibt es keine Updates. Wer also immer die aktuellste KDE- oder Gnome-Version braucht, für den ist Debian definitiv nichts.

Ich habe bei Debian ganz andere Probleme: Zum Ersten muss ich bei der Konfiguration viel mehr auf die Kommandozeile ausweichen oder direkt in die Konfigurations-Dateien schreiben. Suse hat einen da zu sehr mit grafischen Dialogen verwöhnt, die man nun in Etch vermisst.
Zum Zweiten habe ich das Problem, mein Home-Verzeichnis bei der Susi verschlüsselt zu haben. Es liegt auf einer eigenen, verschlüsselten und nach /home/markus gemounteten Partition. Nur arbeitet Suse hier mit dem “Cryptoloop”-Verfahren, während Debian wie viele andere Distributionen auch auf “Cryptsetup” setzt. Beide Verfahren sind nicht kompatibel, und ich bekomme mein Home-Verzeichnis in Etch nicht eingebunden, habe also von Debian aus keinen Zugriff auf meine Daten.

Nun denn, ich denke mal, dass ich die letzte NTFS-Partition jetzt formatieren kann. Die soll dann am besten mit LUKS verschlüsselt werden, das können beide Distris. Dann kann ich von der Susi aus meine Daten alle dahin kopieren oder verschieben, und das Cryptoloop-Device einfach mit ext3 formatieren. Da werde ich Etch dann wohl noch mal neu installieren, denn momentan habe ich eine etwa 7,5 GB kleine Partition für das ganze Debian-System. Nur /home liegt auf einer eigenen Partition, und /home/markus geht im Moment wie gesagt nicht.

Hauppauge Fernbedienung

So Leute, jetzt geht’s zur Sache. Ich bin beim googlen auf das DCOP-Interface gestoßen, über das sich viele KDE-Programme fernsteuern lassen. Dies wird wohl hauptsächlich genutzt, um wiederkehrende Aufgaben per Skript auf der Konsole zu automatisieren, lässt sich aber auch zusammen mit dem Progrämmchen “irexec” nutzen.

Als erstes muss in /etc eine Datei namens lircd.conf liegen, welche die von der Fernbedienung gesendeten Codes enthält, und zwar je Taste. Im falle meiner Hauppauge FB sind das also 45 Codes. Außerdem muss eine Datei namens lircrc vorhanden sein. Die jedoch liegt als versteckte Datei (.lircrc) in meinem Home-Verzeichnis. So kann keder User des PC seine eigene Konfiguration für die Fernbedienung machen.

In der .lircrc werden im ersten Abschnitt verschiedene Modi definiert, und dann je Modus die Funktionen festgelegt. Wie also die Tasten auf meiner FB heißen, habe ich mit dem Befehl “irw” auf der Konsole erfahren. Wenn man nach Eingabe dieses Befehls die Tasten der Fernbedienung Drückt, wird der Code und der Name der Taste in der Konsole angezeigt.

Die programmspezifischen Befehle zur Steuerung der Software habe ich in den jeweiligen Handbüchern in der Hilfe gefunden. So habe ich zunächst Amarok eingerichtet. Ich steuere nun die Lautstärke im Player, nicht mehr die Systemlautstärke. Außerdem lässt sich nun die “Laufwerks-Steuerung” wie bei einem CD-Player bedienen, also Play, Pause, Stop usw., das OSD einblenden, sowie Amarok zum Tray-Symbol minimieren oder ganz beenden. Und natürlich auch durch Aufrufen des Music- oder Radio-Modus starten. Ich werde da aber noch mal weiter schauen, um auch die Playlist zu füttern, in die Radio-Streams zu kommen usw.

Dann habe ich in der .lircrc Kaffeine eingerichtet. Ich kann die Software über Aufruf der Modi TV oder Video starten, die Wiedergabe starten, stoppen oder pausieren, die Lautstärke regeln und über die Zifferntasten umschalten. Trotz korrekter Eingabe weiter Funktionen funktioniert das Zappen noch nicht, und die Menü-Steuerung auf DVDs konnte ich noch nicht testen. Kaffeine will plötzlich keine Codecs mehr für DVDs haben und verweigert an dieser Stelle. Hat aber auch mal geklappt…

Also Ihr seht, die Konfiguration der FB ist ‘ne Menge Tipparbeit in den Konfigurationsdateien. Und nach jeder Änderung muss der lircd neu gestartet werden (als root) und irexec wieder aufgerufen werden (als User). Wenn ich den lircd stoppe (passiert ja beim Neustart), wird auch irexec beendet. Dann darf man nicht vergessen, wieder in den gewünschten Modus zu schalten, selbst wenn die zugehörige Software noch oder schon geöffnet ist.

Wenn ich alles im Griff habe, poste ich hier mal meine .lircrc, um euch bei ähnlichen Problemen Anregungen zu geben.

TV-Karte Hauppauge WinTV Nova-T PCI – Teil 7

Es gab nun länger nichts neues zu berichten, aber nun muss ich mal wieder was schreiben. Die TV-Karte läuft ganz gut, nur die FB will noch immer nicht. Inzwischen habe ich von einem Modul für lirc gelesen, und zwar “lirc_i2c”:

root@cowboy:~# modinfo lirc_i2c
filename:       /lib/modules/2.6.25-9.slh.1-sidux-686/kernel/drivers/input/lirc/lirc_i2c.ko
license:        GPL
author:         Gerd Knorr, Michal Kochanowicz, Christoph Bartelmus, Ulrich Mueller, Stefan Jahn, Jerome Brock
description:    Infrared receiver driver for Hauppauge and Pixelview cards (i2c stack)
srcversion:     97CA73E1E9867FA2A94BA3B
depends:        i2c-core,lirc_dev
vermagic:       2.6.25-9.slh.1-sidux-686 SMP preempt mod_unload 686
parm:           minor:Preferred minor device number (int)
parm:           debug:Enable debugging messages (bool)
root@cowboy:~#

Ich habe das Modul nun geladen, aber es funzt noch immer nicht.

TV-Karte Hauppauge WinTV Nova-T PCI – Teil 6

Hallo allerseits.

Nachdem ich nun die Module soweit geladen habe, läuft die DVB-T-Karte ohne Probleme. Nur, wenn ich das mit der WinDOSe vergleiche, ruckelt die TV-Wiedergabe über Kaffeine ein wenig. Bei dem Redmonder System mit der Original-Software der Karte läuft die Wiedergabe flüssig. Aber auch unter Linux kann man mit dem leichten Ruckeln leben, wenn man nicht gerade Sport guckt.

Viel interessanter ist die Frage: Wie kriege ich die Fernbedienung richtig zum Laufen? Wenn ich das richtig verstanden habe, läuft die als zusätzliche Tastatur. Die sollte ich eigentlich mit LinEAK konfigurieren können, was aber bisher gescheitert ist. Es lassen sich wohl keine zwei Hackbretter damit einrichten. Da ich aber auf die Tasten meiner Multimedia-Tastatur auch nicht verzichten will, funktionieren bei der Fernbedienung zur Zeit nur die Zifferntasten und die Lautstärke-Regelung samt Stummschaltung. Die Programme einfach mal durchzappen ist nicht. Wenn jemand des Rätsels Lösung kennt, ich bin für jeden Tipp dankbar.

Linux auf meinem Notebook

Hallo,

mein Notebook ist schon ein älteres Semester, und ich kann von der Hardware-Leistung nichts Großartiges erwarten. Also bin ich auf der Suche nach einer schlanken und Ressourcenschonenden Linuxdistribution.

Für die Installation von openSUSE 10.2, wie es auf dem PC läuft, reicht der Speicher nicht. Da muss ich schon während Installation auf eine Swap-Partition zurückgreifen. Der Platz fehlt aber dann nachher im System. Außerdem läuft die Susi auf dem Oldtimer nur sehr schleppend.

Dann habe ich Ubuntu getestet, sowohl 6.10 (Edgy Eft), als auch 7.04 (Feisty Fawn). Mit Edgy läuft sogar meine WLAN-Karte “out of the box”, nach dem Upgrade auf Feisty war diese jedoch tot und nicht zum Leben zu erwecken. Also wieder weg mit dem Zeug, außerdem bin ich kein Freund von Gnome. KDE ist mir lieber.

Wer hat schon mal von SAM 2007 gehört? Diese Distri aus Sachsen war der nächste Kanditat. SAM soll auch auf schmaler Hardware flott laufen und sogar 3D-Effekte erlauben. Ich habe also ein ISO-Image für die Live-CD geladen und gebrannt, und das Notebook davon gebootet. Doch sobald der X-Server der Live-Version starten soll, bleibt der Bildschirm schwarz. Auch die LEDs für DVD und HDD weisen auf keine Aktivitäten hin. Will heißen: Das Live-System startet nicht, und somit komme ich auch nicht an den Installieren-Button, der da irgendwo sein soll.

Reibungslos klappte die Installation von Xandros 4, aber das gefiel mir gar nicht. Da hat einer versucht, die KDE-Oberfläche auf das Design aus Redmond zu trimmen, was nicht wirklich gut gelungen ist. Zudem war Xandros noch langsamer als die Susi.

Nachdem ich mit einer Live-CD von Damn Small Linux gar nicht zurecht kam, habe ich wieder Ubuntu Edgy installiert, da das noch halbwegs flott läuft und meine Hardware komplett unterstützt. Allerdings habe ich dann den eigentlich nicht benötigten ndiswrapper installiert, und dann auf Feisty aktualisiert. Mit dem zuvor installierten ndiswrapper und dem Treiber für die WinDOSe konnte ich die WLAN-Karte dann auch zum Betrieb überreden.

Das ist dann auch der jetzt aktuelle Zustand auf dem Notebook, und langsam fängt Ubuntu an, mir zu gefallen. Trotz Gnome. Aber wenn ich noch eine Distri finde, die diese schwache Hardware nicht an die Grenzen der Leistungsfähigkeit bringt, versuche ich noch weitere Wechsel.

Keep it Country,
Markus

Kopete und meine Webcam – Teil 6

Hallo,

ich stelle eben fest, dass Kopete die Webcam-Unterstützung nur für Yahoo! und MSN anbietet, nicht aber für AIM und ICQ.

Die Möglichkeit, Google Talk in Kopete einzubinden, gibt es nicht, aber der Original-Windoof-Client von Google unterstützt ja auch kein Video…

Keep it Country,
Markus