Speichern in GIMP 2.8

Die Tage habe ich mich noch gefreut, dass ich hier unter Kubuntu das GNU Image Manipulation Program, kurz GIMP, in Version 2.8 installiert habe. Doch dann findet man die ersten Schwächen…

GIMP 2.8 Splash ScreenDie Tage habe ich mich noch gefreut, dass ich hier unter Kubuntu das GNU Image Manipulation Program, kurz GIMP, in Version 2.8 installiert habe. Doch dann findet man die ersten Schwächen…

So war ich z.B. überrascht, als ich eine JPG-Datei bearbeitet habe, und die nachher nicht speichern konnte. Es kam die Meldung, dass GIMP nur das eigene XCF-Format speichern kann, JPG, PNG usw. müsse man exportieren. Den Speichern-Dialog musste ich dafür abbrechen, und dann den Exportieren-Dialog neu aufrufen. Was soll das denn jetzt?

Ich habe mich inzwischen ein bisschen schlau gemacht. Es heißt, GIMP öffnet und speichert nur XCF, und kann das andere alles im- und exportieren. Der Grund ist wohl darin zu suchen, dass man professionelle Pixelschieber als Zielgruppe im Visier hat. Die arbeiten bekanntlich gerne mit Ebenen, und möchten diese nicht durch unachtsames Speichern verlieren.

GIMP 2.8 Speichern-Dialog
Der Speichern-Dialog mit der Fehlermeldung in GIMP 2.8

Dazu fällt mir nur ein, dass GIMP bis 2.6 mich einfach darauf hingewiesen hat, wenn das gewünschte Dateiformat keine Ebenen unterstützt und bot mir dann den Export an, falls ein Bild aus mehreren Ebenen besteht. In Version 2.8 muss ich den Speichervorgang abbrechen, und die komplette Prozedur im Exportieren-Dialog noch mal durchgehen. Schlecht gelöst von den Machern, aber ich gehöre ja auch nicht zur Zielgruppe…

Zudem erinnere ich mich an Windows-Zeiten, in denen ich mit Macromedia Fireworks gearbeitet habe. Und das konnte zumindest PNG auch mit Ebenen speichern. Ich habe damals nämlich Buttons erstellt, und ich konnte die PNGs hinterher öffnen und die Texte ändern.

Abhilfe verspricht ein Python-Skript als GIMP-Plugin, das im Datei-Menü für einen neuen Eintrag sorgt, der auch über die Tastenkombination Stgr+S angesteuert werden kann. Damit soll GIMP dann auch wieder PNG, JPG und die anderen unterstützten Formate speichern können, ohne extra den Exportieren-Dialog aufrufen zu müssen.

Links zum Thema:

Im Monent keine Lust

Hallo Leute, im Moment ist mir die Lust an Linux vergangen. Nach diversen Problemen, über die ich hier zuletzt berichtet habe, läuft im Moment garnix mehr…

Hallo Leute, im Moment ist mir die Lust an Linux vergangen. Nach diversen Problemen, über die ich hier zuletzt berichtet habe, läuft im Moment garnix mehr…

Der Fall Netbook: Nachdem Debian mich letztens nach einem Update mit Gnome 3 überrascht hat, habe ich zunächst Xfce installiert. Das Problem: Das Dock am unteren Bildrand lässt sich nicht ausblenden, und das wirkt auf dem kleinen Display eines Netbooks (1024x600px) störend. Also habe ich mich für das in meinen Augen kleinere Übel entschieden: KDE.

Ich habe die KDE-Pakete installiert, inkl. dem Windowmanager KDM, und die Gnome- und Xfce-Pakete samt dem Gnome-Windowmanager GDM deinstalliert. Ergebnis: Beim Start erscheint das Anmeldefenster des KDM, das war es dann aber auch. Ich kann mich nicht anmelden, die Maschine nicht herunter fahren, neu starten, nichts. Ich lande nach jeder Aktion wieder am Anmeldebildschirm. Nur per [Strg][Alt][F1] auf die Konsole umschalten geht. Da kann ich mich auch anmelden, aber zum Arbeiten ist mir das zu unkomfortabel…

Am PC habe ich auch die Probleme mit diesem Gnome 3, aber da habe ich eh keine 3D-Unterstützung. Die würde mir der Nvidia-Treiber bringen, aber der hat dafür gesorgt, dass der X-Server überhaupt nicht mehr gestartet ist. Eine Deinstallation des Treibers ist die Lösung gewesen, aber eben um den Preis der fehlenden 3D-Unterstützung.

Die ist zwar zum Arbeiten und Surfen nicht unbedingt notwendig, aber das ein oder andere Spielchen darf auch mal sein

Im Moment hab ich so gar keine Lust mehr, mich mit den dauernden Verschlimmbesserungen rumzuschlagen, die einem mit beinahe jedem Update untergeschoben werden. Und wie mir Twitter-Timeline und Google+ Stream verraten, stehe ich da nicht alleine. Es gibt sogar eingefleischte Linuxer, die sich inzwischen ein Mac-Book zugelegt haben. O.o

Google installiert eigenmächtig Apps

Letzte Tage habe ich mich schon darüber geärgert, dass Google mir ungefragt die Apps „TalkBack”, „KickBack” und „SoundBack” auf mein Desire gepackt hat, aber ich konnte das deinstallieren…

Android LogoLetzte Tage habe ich mich schon darüber geärgert, dass Google mir ungefragt die Apps „TalkBack”, „KickBack” und „SoundBack” auf mein Desire gepackt hat, aber ich konnte das deinstallieren…

KickBack im Market
KickBack, im Market nicht verfügbar…
Heute früh, als ich auf dem Heimweg von der Nachtschicht war, wurden mir diese Apps erneut installiert, diesmal ohne die Option zur Deinstallation. Die Tage kam das als Update, ich habe das Automatische Update dieser Apps untersagt, und das Update deinstalliert. Jetzt zeigt mir der Market, dass diese Artikel nicht verfügbar sein…

Jetzt hab ich dem Müll auf dem Smartphone, und bekomme es erst mal nicht wieder weg. Das kotzt mich an, weil ich diese Dinger nie haben wollte. Mein Handy ist mein Eigentum, und welche Software darauf läuft, will ich gefälligst alleine entscheiden. Auch ein Riese wie Google hat mich da nicht zu bevormunden! In den Bewertungen im Market wird von anderen Betroffenen auch bereits fleißig gemeckert. Und mit was? Mit Recht! :motz:

Anyway, nachdem ich schon bei Google+ gemeckert habe, und dort einige Reaktionen bekam, wurde dort auch ein Link zu einem Google-Blog gepostet, denn ich der Vollständigkeit halber hier nicht unterschlagen will:
http://google-opensource.blogspot.com/2009/10/talkback-open-source-screenreader-for.html

Kein ICQ mehr in Kopete [Update]

Gestern ist mir aufgefallen, dass KDE’s Instant-Messenger Kopete keine Verbindung zu ICQ aufbauen konnte. Ich wurde immer wieder aufgefordert, mein Passwort einzugeben, da dies falsch sein sollte…
Da meine Frau mit Pidgin ebenfalls keine Verbindung zu ICE bekam, machte ich mich mal im Netz auf die Suche. Ergebnis: Jeder, der nicht die originale ICQ-Software verwendet, hat aktuell ein Problem. ICQ hat scheinbar was am Protokoll geändert, was auch nicht zum ersten mal vorkommt.

KopeteGestern ist mir aufgefallen, dass KDE’s Instant-Messenger Kopete keine Verbindung zu ICQ aufbauen konnte. Ich wurde immer wieder aufgefordert, mein Passwort einzugeben, da dies falsch sein sollte…

ICQ-LogoDa meine Frau mit Pidgin ebenfalls keine Verbindung zu ICQ bekam, machte ich mich mal im Netz auf die Suche. Ergebnis: Jeder, der nicht die originale ICQ-Software verwendet, hat aktuell ein Problem. ICQ hat scheinbar was am Protokoll geändert, was auch nicht zum ersten mal vorkommt.

Da bleibt wohl nur die Möglichkeit, auf Updates für die Multi-Messenger zu warten…

Update 18.11.2010, 16:45 Uhr: War schon spät gestern Abend, ich habe den Kommentar von Ingo falsch verstanden… :blush: Auf den richtigen Weg brchte mich heute Vormittag eine Twitter-Message, die zwar gestern schon gesendet wurde, die ich aber erst heute gesehen habe…

Also nochmal langsam für alle Legastheniker (wie mich ): Man öffne in Kopete Einstellungen → Einrichten …, wählt den ICQ-Zugang aus und klickt auf Zugang bearbeiten …. Im Register Zugangseinstellungen bei Standardserverinformationen übergehen den Haken in die Checkbox setzen, und die Adresse login.messaging.aol.com ändern in login.icq.com. Siehe auch zum Vergleich auch den Screenshot unten.

Kopete-Einstellungen für ICQ
Die Einstellungen für ICQ müssen in Kopete geändert werden

Stress mit dem PC dem Blog

Vor gut einer Woche ist mein PC nach einigen Problemen mit der Hardware endgültig abgeraucht. Mainboard, CPU, eins von beiden hat sich verabschiedet.

Ich habe inzwischen einen neuen PC hier in Betrieb, der der im Vergleich zum alten eine Rennmaschine ist. Das war eine Sockel-A-Board mit einem AMD Athlon XP 2200+ und 768 MB Speicher. Hat für meine Zwecke gereicht, nur beim Einsatz einer virtuellen Maschine wurde es eng.

Jetzt steht hier eine 64-Bit-Maschine mit einem AMD Dual Core mit 5200 MHz und 2 GB Speicher. Einzig der Grafik-Chip macht mich nicht glücklich. Eigentlich ist es ein recht guter nVidia-Chip, leider onboard. Die 512 MB Grafikspeicher werden dem RAM abgezwackt, wie bei diesen Lösungen üblich. Die Video-Wiedergabe ruckelt, man mag es nicht glauben. Besonders heftig fällt das bei TV auf. Obwohl das Board einen DVI-Ausgang hat.

Ich habe allerdings noch keine Linux-Version vernünftig zum Laufen bekommen. Die Lautsprechern blieben Stumm, der Grafik-Chip wollte sich trotz nVidia-Treiber nicht korrekt einstellen lassen, und es gab USB-Probleme.

Um überhaupt mit der Maschine arbeiten zu können, habe ich zunächst mal eine WinDOSe installiert. Ich könnte kotzen…

Und dann hatte ich plötzlich mit meinen Blogs Probleme. Alle 3 Blogs ließen sich von jetzt auf gleich nicht mehr aufrufen, lieferten nur eine leere, weiße Seite zurück. Egal, ob im Front- oder Backend. Nachdem ich im Country-Blog mit Reparaturversuchen und Abschaltung von Plugins endlich erfolgreich war, brachten die gleichen Maßnahmen bei Anja’s Blog nichts. Hier im Linux-Blog habe ich gar nichts gemacht. Und jetzt eben, genau so unerwartet, funktioniert alles wieder O.o

Ich habe langsam keine Lust mehr…