Kein ICQ mehr in Kopete [Update]

Gestern ist mir aufgefallen, dass KDE’s Instant-Messenger Kopete keine Verbindung zu ICQ aufbauen konnte. Ich wurde immer wieder aufgefordert, mein Passwort einzugeben, da dies falsch sein sollte…
Da meine Frau mit Pidgin ebenfalls keine Verbindung zu ICE bekam, machte ich mich mal im Netz auf die Suche. Ergebnis: Jeder, der nicht die originale ICQ-Software verwendet, hat aktuell ein Problem. ICQ hat scheinbar was am Protokoll geändert, was auch nicht zum ersten mal vorkommt.

KopeteGestern ist mir aufgefallen, dass KDE’s Instant-Messenger Kopete keine Verbindung zu ICQ aufbauen konnte. Ich wurde immer wieder aufgefordert, mein Passwort einzugeben, da dies falsch sein sollte…

ICQ-LogoDa meine Frau mit Pidgin ebenfalls keine Verbindung zu ICQ bekam, machte ich mich mal im Netz auf die Suche. Ergebnis: Jeder, der nicht die originale ICQ-Software verwendet, hat aktuell ein Problem. ICQ hat scheinbar was am Protokoll geändert, was auch nicht zum ersten mal vorkommt.

Da bleibt wohl nur die Möglichkeit, auf Updates für die Multi-Messenger zu warten…

Update 18.11.2010, 16:45 Uhr: War schon spät gestern Abend, ich habe den Kommentar von Ingo falsch verstanden… :blush: Auf den richtigen Weg brchte mich heute Vormittag eine Twitter-Message, die zwar gestern schon gesendet wurde, die ich aber erst heute gesehen habe…

Also nochmal langsam für alle Legastheniker (wie mich ): Man öffne in Kopete Einstellungen → Einrichten …, wählt den ICQ-Zugang aus und klickt auf Zugang bearbeiten …. Im Register Zugangseinstellungen bei Standardserverinformationen übergehen den Haken in die Checkbox setzen, und die Adresse login.messaging.aol.com ändern in login.icq.com. Siehe auch zum Vergleich auch den Screenshot unten.

Kopete-Einstellungen für ICQ
Die Einstellungen für ICQ müssen in Kopete geändert werden

Wo bleiben die Anfragen?

Dass ich als KDE-Anwender bei Instant Messaging auf Kopete setze, sollte klar sein. Ich habe da noch drei aktive Accounts drin, u.A. ICQ. Und zumindest da liegt das Problem.

Ich bin informiert worden, dass mich jemand im ICQ geaddet hat. Nur ist die Autorisierungs-Anfrage bei nicht angekommen. Auch ein zweiter Versuch schlug fehl.

Kopete-LogoDass ich als KDE-Anwender bei Instant Messaging auf Kopete setze, sollte klar sein. Ich habe da noch drei aktive Accounts drin, u.A. ICQ. Und zumindest da liegt das Problem.

Ich bin informiert worden, dass mich jemand im ICQ geaddet hat. Nur ist die Autorisierungs-Anfrage bei nicht angekommen. Auch ein zweiter Versuch schlug fehl.

Derjenige, der mich adden wollte, ist Nutzer einer WinDOSe, hat also mit 99%er Wahrscheinlichkeit die Original-Software von ICQ. Multi-Messenger sind auf der Redmonder Plattform wohl nicht so verbreitet.

Jetzt gehe ich mal davon aus, dass die O-Software da keine Probleme beim Adden macht. Hab ich von früher her auch noch so in Erinnerung. Demzufolge muss das Problem bei meinem Kopete liegen. Ich verwende hier aktuell Version 0.12.7 auf KDE 3.5.9.

ICQ-LogoMit Kopete hatte ich aber leider schon mehrfach Probleme, wenn es um das ICQ-Protokoll ging. Ich erinnere mich, dass da auch mal der Datei-Transfer streikte. Ich weiß nicht, wo ich noch suchen soll, die Kopete-Optionen geben ja nicht allzuviel her. Und in meinem ICQ-Profil habe schon eine halbe Ewigkeit nicht mehr rumgespielt…

Ob die Probleme auch mit anderen Protokollen als ICQ auftreten, weiß ich nicht. AIM verbindet sich nach der Zwangstrennung meines Providers nachts um 2 nicht wieder neu, und ich vergesse immer, das manuell nachzuholen. Und Jabber / GoogleTalk nutzt kaum einer von meinen Bekannten.

Ich überlege schon, ob ich mir ein paar Gnome-Bibliotheken auf den Rechner schaufeln und dann auf Pidgin umsteigen soll.

Wenn einer von Euch die Lösung des Problemes kennt, dann einfach mal raus damit.

Kopete und meine Webcam – Teil 6

Hallo,

ich stelle eben fest, dass Kopete die Webcam-Unterstützung nur für Yahoo! und MSN anbietet, nicht aber für AIM und ICQ.
 

Hallo,

ich stelle eben fest, dass Kopete die Webcam-Unterstützung nur für Yahoo! und MSN anbietet, nicht aber für AIM und ICQ.

Die Möglichkeit, Google Talk in Kopete einzubinden, gibt es nicht, aber der Original-Windoof-Client von Google unterstützt ja auch kein Video…

Keep it Country,
Markus

Kopete und meine Webcam – Teil 5

So langsam wird’s…

Nun läuft die Labtec Webcam auch, und Kopete arbeitet damit zusammen Nun sind endlich wieder Videokonferenzen möglich. Nur Skype für Linux müsste das noch unterstüzen…
 

So langsam wird’s…

Nun läuft die Labtec Webcam auch, und Kopete arbeitet damit zusammen Nun sind endlich wieder Videokonferenzen möglich. Nur Skype für Linux müsste das noch unterstüzen…

Nachdem ich ja die Tage Linux neu installiert habe, habe ich vorhin den Webcam-Treiber aus den Quellen neu übersetzt und installiert. Da ist mir aufgefallen, dass das deutlich besser ablief, als beim letzten mal. Da gab es nämlich Fehlermeldungen, heute klappte es ohne…

Zum Schluss noch das frisch installierte Kernelmodul laden und auch in die /etc/modprobe.conf eintragen, und ich habe zwei Video-Devices: /dev/video0 ist die TV-Karte, /dev/video1 die Kamera.

Kopete und meine Webcam – Teil 4

Hallo Leute,

jetzt ist meine „neue” Webcam, eine Labtec USB WebCam Pro, vor einer Woche angekommen. Die soll Linux-kompatibel sein, laut Suse Hardware-Datenbank.
 

Hallo Leute,

jetzt ist meine „neue” Webcam, eine Labtec USB WebCam Pro, vor einer Woche angekommen. Die soll Linux-kompatibel sein, laut Suse Hardware-Datenbank.

Fakt ist: Trotz Installation der Treiber habe ich diesem Ding noch nicht ein Bild entlocken können.

Meine Halsschlagader ist kurz vorm Platzen…

Kopete und meine Webcam – Teil 3

Na gut, in Sachen Webcam gibt’s nichts neues zu berichten. Aber Kopete zeigt sich teilweise recht merkwürdig, seit ich diesen Patch angewendet habe.

Die Konten von MSN und Yahoo! laufen tadellos, aber irgendwie sehe ich beim AIM und auch beim ICQ nicht mehr, wer gerade online ist. Meine Kontakte sind alle da, für beide Protokolle.

Na gut, in Sachen Webcam gibt’s nichts neues zu berichten. Aber Kopete zeigt sich teilweise recht merkwürdig, seit ich diesen Patch angewendet habe.

Die Konten von MSN und Yahoo! laufen tadellos, aber irgendwie sehe ich beim AIM und auch beim ICQ nicht mehr, wer gerade online ist. Meine Kontakte sind alle da, für beide Protokolle. Die werden aber grundsätzlich als offline angezeigt, obwohl ich genau weiß, dass der ein oder andere online ist und das auch so anzeigen lassen.

Jetzt geht das Gesuche los, wo der Fehler liegt. Vermutlich muss ich jetzt mal die Installation der gepatchten Version suchen und entfernen, um anschließend wieder die Original-Version der Distri zu installieren. Und dafür hab ich mir die ganze Arbeit gemacht… Ärgerlich :evil:

Kopete und meine Webcam – Teil 2

So, jetzt habe ich mich endlich dazu durchringen können, die ganze Prozedur nochmal zu machen.

Als erstes habe ich die Patch-Datei eine Verzeichnisebene höher geschoben und da mit „Kompare” geöffnet. Jetzt ließen sich die Änderungen auch per Mausklick übernehmen, ich habe nicht drei Stunden lang Dateien gesucht und händisch editiert.

So, jetzt habe ich mich endlich dazu durchringen können, die ganze Prozedur nochmal zu machen.

Als erstes habe ich die Patch-Datei eine Verzeichnisebene höher geschoben und da mit „Kompare” geöffnet. Jetzt ließen sich die Änderungen auch per Mausklick übernehmen, ich habe nicht drei Stunden lang Dateien gesucht und händisch editiert.

Das Gemecker von „./configure” war immer noch, aber dafür lief „make” ohne Fehlermeldung durch, diesmal eine gefühlte Stunde lang. Dann habe ich mich mal eben mit „su” zum Adminuser „root” gemacht und mit „make install” Kopete neu installiert.

Nun gut, die Software läuft wieder. Und da ich mein Profilverzeichnis nicht gelöscht habe, sind auch meine Kontaktlisten alle noch da, ebenso meine Konten.

Wenn ich jetzt „Einstellungen -> Einrichten…” wähle, und dann auf Geräte gehe, sehe ich erst mal keine Änderung. Ich habe Kopete dann mal geschlossen und UVCview geöffnet, um die Kamera noch mal zu prüfen. Alles Takko. Jetzt habe ich Kopete bei weiterhin geöffnetem UVCview neu gestartet und wieder den Einstellungs-Dialog aufgerufen. Jetzt hatte ich zwar eine Reaktion von der Webcam, sah aber nur ein sehr grobes Artefakt-Muster. Wenn ich versuche, mit den Reglern Helligkeit, Kontrast usw. einzustellen, stürzt Kopete ab. Game over. :evil:

Also bleibt nur zu hoffen, dass die bestellte Labtec-Kamera schnell ankommt…

Kopete und meine Webcam – Teil 1

Im Moment bin ich ein wenig frustriert. :evil:

Aber von Anfang an:
Der Kollege, der mir die Anleitung zum Einbinden der Webcam gegeben hat, hat mit auch zwei Links gegeben.

Im Moment bin ich ein wenig frustriert. :evil:

Aber von Anfang an:
Der Kollege, der mir die Anleitung zum Einbinden der Webcam gegeben hat, hat mit auch zwei Links gegeben. Die dahinter liegenden Anleitungen sollen wohl dafür sorgen, dass Kopete auf die Kamera zugreifen kann.

Da dies nun bedeutet, Kopete neu zu installieren, habe ich erstmal die installierte Version mit YaST entfernt und mir dann von der Projekthomepage die aktuellen Sourcen von Kopete gezogen, ferner einen Patch zu dieser Sourcen.

Demnach muss ich etwa zehn Dateien aus dem Source-Paket patchen und zwei weitere Dateien dem Paket hinzufügen. Habe ich gemacht. Dann soll das Programm kompliert und installiert werden, und da geht’s dann los:

./configure” meckert, dass die Developement-Pakete von XMMS und OpenSLP nicht installiert sind. Die XMMS-Pakete sind aber definitiv da, und zu OpenSLP finden sich auf meiner Linux-DVD keine devel-Pakete. Wäre vielleicht eine Alternative, aktuelle Pakete aus dem Netz zu laden. Außerdem würden die Pakete für Jabber Jingle fehlen. Jabber habe ich schon mal gehört, aber Jingle? Ist mir neu/hellip;

Egal, die fehlenden Pakete sind auch nicht unbedingt erforderlich, da mir nur einige Funktionen fehlen. Also habe ich Schritt zwei aus dem Installations-Dreisatz ausgeführt: Den Befehl „make”.

Nun kam ich mir in meinem Terminal vor wie in der Matrix. Grüne Schrift raste über den Bildschirm, gefühlte zehn Minuten lang. Dann kam die Fehlermeldung: Irgendein Verzeichnis oder eine Datei konnte nicht erstellt werden. Aktion abgebrochen. Frust. :evil:

Den letzten Schritt brauchte ich also garnicht mehr zu starten. Ich vermute mal, dass mir beim Patchen der Sourcen ein Fehler unterlaufen ist. Da ich KDevelop nicht dazu überreden konnte, die Patches automatisch zu übernehmen, musste ich das von Hand machen. Fehlerträchtige Angelegenheit. Da man ja kein Programmierer ist, weiß man auch nicht so genau, was man da tut.

Nun gut, ich habe alles gelöscht und die Sourcen neu geladen. Jetzt muss ich alles wieder patchen und dann eine neue Installation versuchen.

Aber erst mal gehe ich jetzt in’s Bett und schlaf ’ne Runde. Ich mache schon hier beim Schreiben genug Fehler, da muss ich mich jetzt nicht an die Sourcen wagen…

Unerwartete Wendung

Da habe ich gestern Abend einen in einem Forum eine Anleitung bekommen, wie ein Leidensgenosse seine Logitech QuickCam Pro 5000 unter Linux (in diesem Fall Ubuntu Feisty Fawn) ans Laufen brachte

Nun musste ich für openSUSE diverse kleine Änderungen an dieser Anleitung vornehmen.

Da habe ich gestern Abend einen in einem Forum eine Anleitung bekommen, wie ein Leidensgenosse seine Logitech QuickCam Pro 5000 unter Linux (in diesem Fall Ubuntu Feisty Fawn) ans Laufen brachte

Nun musste ich für openSUSE diverse kleine Änderungen an dieser Anleitung vornehmen, aber es klappte. Mit dem Programm „UVCview” kann ich auf die Kamera zugreifen und und habe meine Livebilder. Nun geht es mir da drum, die Kamera in Kopete einzubinden. Im gleichen Forumthread steht aber auch, das Video4Linux (v4l) & Co nichts mit dem UVC-Stream anfangen können O.o

Schau’mer mal, wie der Kaiser zu sagen pflegt…

Hier geht übrigens zum angesprochenen Thead.