Vorbei ist´s mit der Ruhe

Da schreibe ich Anfang des Monats, dass alles gut läuft, und dann dieses:

Ich hatte an meinem PC einen Festplattencrash, und nun meine Systeme neu installiert. Jetzt habe ich zwei dicke Probleme, und ein kleineres dazu:
 

Da schreibe ich Anfang des Monats, dass alles gut läuft, und dann dieses:

Ich hatte an meinem PC einen Festplattencrash, und nun meine Systeme neu installiert. Jetzt habe ich zwei dicke Probleme, und ein kleineres dazu:

Als erstes fällt auf, dass die Maus nicht mehr funktioniert. Ich habe hier eine recht einfache, kabelgebundene Maus von Logitech, die über einen Adapter am PS/2-Port hängt. Die Hardware ist soweit OK, denn an der parallel installierten WinDOSe funktioniert die Maus tadellos. Stecke ich die hier unter Sidux an den USB-Port, funktioniert die Maus auch hier. Nur eben die Kombination PS/2-Sidux mag nicht mehr klappen

Da zu kommt, dass ich nicht genügend USB-Ports frei habe. So habe ich die Webcam abgestöpselt, die das kleine Problem darstellt. Ich war froh, dass die Cam mit dem gspca-Modul lief, aber das Modul scheint es für den aktuellen Sidux-Kernel nicht mehr zu geben. Anyway, das müsste notfalls eigentlich aus den Quellen zu übersetzen sein, werde ich später mal versuchen O.o

Denn immer noch ist ein dickes Problem übrig: Die Hauppauge Fernbedienung und lirc. Ich habe jetzt nach langem Hin und Her und Hilfe aus dem Linux-Forum den lirc-Dämon am laufen, allerdings reagiert der nicht auf die Befehle der Fernbedienung. Die kommen aber definitiv an, denn irw gibt die empfangenen Tastendrucke zurück. Warum irexec die dann nicht umsetzt, ist mir ein Rätsel :evil:

Was mich dabei auch wiederum wundert, sind die Kernel-Module. Nötig ist lirc_i2c, aber ich hatte vor dem Crash auch noch lirc_gpio eingerichtet, welches sich in den aktuellen Sourcen der lirc-Module nicht mehr findet

Also jetzt bin ich für nützliche Hinweise dankbar, bitte in die Kommentrare damit

Der aktuelle Stand

Dann will ich Euch erst mal auf den aktuellen Stand der Dinge bringen:

Seit Weihnachten etwa setze ich auf meinem PC Sidux ein, welches auf Debian Sid basiert. Sid ist der Entwicklerzweig von Debian, und ich bekomme immer die aktuellen Programmversionen.

Inzwischen habe ich Sidux auch auf dem Notebook installiert, und auf den PC meiner Frau und meiner Tochter. Beide kommen auch sehr gut damit klar.

Die Installation von Sidux auf dem Notebook war ein echter Kampf. Diese Antiquität hat sich mal wieder geziert bis zum Gehtnichtmehr. Ich musste erst Debian Etch installieren, und dann über eine angepasste sources.list auf Sidux upgraden. Aber irgendwas fehlt da noch, da sich das System noch nicht als Sidux identifiziert. Wenn ich das Update-Script „smxi“ laufen lasse, meckert das immer über eine zu alte Debian-Version…

Iceweasel und Icedove kommen als Browser bzw. Mailer zum Einsatz, nur auf meinem PC bin ich letzte Tage von Icedove nach KMail umgestiegen. Ich bekam in Icedove alle halbe Stunde eine Fehlermeldung über ein nicht reagierendes Script. Das kann eigentlich nur irgend eine Erweiterung verursacht haben, ich habe aber nichts neues installiert.

Meine Wabcam läuft, und zwar die teure QC 5000 Pro. Mit dem UVC-Treiber lief die zwar auch schon unter SuSE, ließ sich da aber nicht zur Zusammenarbeit mit Kopete überreden. Das klappt aber jetzt, und inzwischen unterstützt Skype für Linux ja auch Video

Meine neueste Errungenschaft in Sachen Hardware ist ein Kombigerät, Drucker, Scanner, Kopierer, Fax. Es ist das MFC-235C von Brother, das hier klaglos seinen Dienst verrichtet. Brother bietet Linux-Treiber zum Download an, und die funktionieren hervorragend. Ich musste zwar noch udev-Regeln erstellen, um als gemeiner User auf den Scanner zugreifen zu können, aber nach einigem Suchen im Netz habe ich auch das hinbekommen. Poste ich vielleicht noch mal in einem extra Artikel was zu.

Wenn ich mich noch über was ärgere, dann nach wie vor die Hauppauge Fernbedienung. Ich konnte zwar inzwischen einige Funktionen über die Shortcuts von Kaffeine erreichen, jedoch nicht mit den dafür eigentlich vorgesehenen Tasten. Kaffeine scheint nicht alle Tasten der Fernbedienung zu erkennen, obwohl „irw“ auf der Konsole auf alle Tasten reagiert und die Codes anzeigt.

So weit bin ich also nun mit meinen Systemen hier zufrieden, einzig der Update-Aufwand bei Sidux ist enorm. 150 bis 200 MB am Tag sind keine Seltenheit. Auf meinem PC jetzt, auf den anderen fällt nicht so viel an, da nicht so viel installiert ist.

Kopete und meine Webcam – Teil 2

So, jetzt habe ich mich endlich dazu durchringen können, die ganze Prozedur nochmal zu machen.

Als erstes habe ich die Patch-Datei eine Verzeichnisebene höher geschoben und da mit „Kompare” geöffnet. Jetzt ließen sich die Änderungen auch per Mausklick übernehmen, ich habe nicht drei Stunden lang Dateien gesucht und händisch editiert.

So, jetzt habe ich mich endlich dazu durchringen können, die ganze Prozedur nochmal zu machen.

Als erstes habe ich die Patch-Datei eine Verzeichnisebene höher geschoben und da mit „Kompare” geöffnet. Jetzt ließen sich die Änderungen auch per Mausklick übernehmen, ich habe nicht drei Stunden lang Dateien gesucht und händisch editiert.

Das Gemecker von „./configure” war immer noch, aber dafür lief „make” ohne Fehlermeldung durch, diesmal eine gefühlte Stunde lang. Dann habe ich mich mal eben mit „su” zum Adminuser „root” gemacht und mit „make install” Kopete neu installiert.

Nun gut, die Software läuft wieder. Und da ich mein Profilverzeichnis nicht gelöscht habe, sind auch meine Kontaktlisten alle noch da, ebenso meine Konten.

Wenn ich jetzt „Einstellungen -> Einrichten…” wähle, und dann auf Geräte gehe, sehe ich erst mal keine Änderung. Ich habe Kopete dann mal geschlossen und UVCview geöffnet, um die Kamera noch mal zu prüfen. Alles Takko. Jetzt habe ich Kopete bei weiterhin geöffnetem UVCview neu gestartet und wieder den Einstellungs-Dialog aufgerufen. Jetzt hatte ich zwar eine Reaktion von der Webcam, sah aber nur ein sehr grobes Artefakt-Muster. Wenn ich versuche, mit den Reglern Helligkeit, Kontrast usw. einzustellen, stürzt Kopete ab. Game over. :evil:

Also bleibt nur zu hoffen, dass die bestellte Labtec-Kamera schnell ankommt…

Unerwartete Wendung

Da habe ich gestern Abend einen in einem Forum eine Anleitung bekommen, wie ein Leidensgenosse seine Logitech QuickCam Pro 5000 unter Linux (in diesem Fall Ubuntu Feisty Fawn) ans Laufen brachte

Nun musste ich für openSUSE diverse kleine Änderungen an dieser Anleitung vornehmen.

Da habe ich gestern Abend einen in einem Forum eine Anleitung bekommen, wie ein Leidensgenosse seine Logitech QuickCam Pro 5000 unter Linux (in diesem Fall Ubuntu Feisty Fawn) ans Laufen brachte

Nun musste ich für openSUSE diverse kleine Änderungen an dieser Anleitung vornehmen, aber es klappte. Mit dem Programm „UVCview” kann ich auf die Kamera zugreifen und und habe meine Livebilder. Nun geht es mir da drum, die Kamera in Kopete einzubinden. Im gleichen Forumthread steht aber auch, das Video4Linux (v4l) & Co nichts mit dem UVC-Stream anfangen können O.o

Schau’mer mal, wie der Kaiser zu sagen pflegt…

Hier geht übrigens zum angesprochenen Thead.

Webcam will nicht

Ich habe aus den Tagen mit Winzigweich Fenster (freie Übersetzung ) noch eine Webcam am PC angeschlossen. Dabei handelt es sich um eine Logitech QuickCam Pro 5000, die verdammt nicht billig war.

Das Ding verweigert aber unter Linux seinen Dienst.

Ich habe aus den Tagen mit Winzigweich Fenster (freie Übersetzung ) noch eine Webcam am PC angeschlossen. Dabei handelt es sich um eine Logitech QuickCam Pro 5000, die verdammt nicht billig war.

Das Ding verweigert aber unter Linux seinen Dienst, so dass ich mir eine ClickSmart 310, ebenfalls von Logitech, ersteigert habe. Nur werde ich diese Kamera nicht bekommen, da die Verkäuferin sie nicht finden kann. Nun habe ich eine Labtec WebCam Pro ersteigert, auf die ich nun warte. Ich bin gespannt, denn für dieses Teil habe ich mich nach einem Blick in die Hardware-Datenbank von Suse entschieden. Die Kamera war zwar nur mit openSUSE 10.0 getestet, und die Treiber müssten manuell installiert werden. Ich werde ja sehen, ob ich das Ding unter openSUSE 10.2 zum Laufen kriege.