Kopete und meine Webcam – Teil 1

Im Moment bin ich ein wenig frustriert. :evil:

Aber von Anfang an:
Der Kollege, der mir die Anleitung zum Einbinden der Webcam gegeben hat, hat mit auch zwei Links gegeben. Die dahinter liegenden Anleitungen sollen wohl dafür sorgen, dass Kopete auf die Kamera zugreifen kann.

Da dies nun bedeutet, Kopete neu zu installieren, habe ich erstmal die installierte Version mit YaST entfernt und mir dann von der Projekthomepage die aktuellen Sourcen von Kopete gezogen, ferner einen Patch zu dieser Sourcen.

Demnach muss ich etwa zehn Dateien aus dem Source-Paket patchen und zwei weitere Dateien dem Paket hinzufügen. Habe ich gemacht. Dann soll das Programm kompliert und installiert werden, und da geht’s dann los:

./configure” meckert, dass die Developement-Pakete von XMMS und OpenSLP nicht installiert sind. Die XMMS-Pakete sind aber definitiv da, und zu OpenSLP finden sich auf meiner Linux-DVD keine devel-Pakete. Wäre vielleicht eine Alternative, aktuelle Pakete aus dem Netz zu laden. Außerdem würden die Pakete für Jabber Jingle fehlen. Jabber habe ich schon mal gehört, aber Jingle? Ist mir neu/hellip;

Egal, die fehlenden Pakete sind auch nicht unbedingt erforderlich, da mir nur einige Funktionen fehlen. Also habe ich Schritt zwei aus dem Installations-Dreisatz ausgeführt: Den Befehl „make”.

Nun kam ich mir in meinem Terminal vor wie in der Matrix. Grüne Schrift raste über den Bildschirm, gefühlte zehn Minuten lang. Dann kam die Fehlermeldung: Irgendein Verzeichnis oder eine Datei konnte nicht erstellt werden. Aktion abgebrochen. Frust. :evil:

Den letzten Schritt brauchte ich also garnicht mehr zu starten. Ich vermute mal, dass mir beim Patchen der Sourcen ein Fehler unterlaufen ist. Da ich KDevelop nicht dazu überreden konnte, die Patches automatisch zu übernehmen, musste ich das von Hand machen. Fehlerträchtige Angelegenheit. Da man ja kein Programmierer ist, weiß man auch nicht so genau, was man da tut.

Nun gut, ich habe alles gelöscht und die Sourcen neu geladen. Jetzt muss ich alles wieder patchen und dann eine neue Installation versuchen.

Aber erst mal gehe ich jetzt in’s Bett und schlaf ‘ne Runde. Ich mache schon hier beim Schreiben genug Fehler, da muss ich mich jetzt nicht an die Sourcen wagen…