Bald kein TweetDeck mehr

Wie heute mehrere Newsportale melden, will Twitter sich bei TweetDeck auf die WebApp und die Chrome-Erweiterung konzentrieren. Die Apps für iOS und Android sollen eingestellt werden, ebenso wie die alte Air-Version.

TweetDeck-Logo altWie heute mehrere Newsportale melden, will Twitter sich bei TweetDeck auf die WebApp und die Chrome-Erweiterung konzentrieren. Die Apps für iOS und Android sollen eingestellt werden, ebenso wie die alte Air-Version.

Die Version für Adobe Air wurde ja bereits mit dem Kauf von TweetDeck durch Twitter eingestellt und statt dessen eine nur halb so gute native Anwendung für Windows und Mac veröffentlicht. Linux wird seit dem nicht mehr unterstützt. Am 1. Mai sollen nun die Versionen für iOS und Android aus App- und Play-Store verschwinden.

Während mir die Mobil-Versionen nicht wirklich fehlen werden, weil ich kein iOS habe und auf Android den TweetCaster oder die native Twitter-App nutze, tut es mir um die unter Ubuntu genutzte Air-Version leid.

Die Funktion dürfte allerdings schon um einiges eher nicht mehr gegeben sein, da Twitter angeblich die von TweetDeck genutzte API noch in diesem Monat abschalten will. Damit darf ich mich wieder auf die Suche nach einem neuen Client machen, der folgende Anforderungen erfüllen sollte:

  1. Mehrere Konten, auch ohne zwischen ihnen hin- und herschalten zu müssen
  2. Unterstützung von Twitter und identi.ca
  3. Mehrspaltenansicht, auch die Timelines mehrerer Konten nebeneinander
  4. Selektives Posten auf einen oder mehrere Accounts

So, jetzt seid Ihr dran. Denn einen Microblogging-Client für Linux, der diese Anforderungen erfüllt, habe ich noch nicht gefunden…

Links zum Thema:

Kein Adobe Air unter Unity?

Nachdem ich die Tage Ubuntu neu installiert hab, hadere ich schon wieder damit. Ich bekomme meinen Lieblings-Twitter-Client TweetDeck nicht installiert, weil sich dass dafür benötigte Air-Framework von Adobe unter Unity nicht installieren lässt…

TweetDeck-Logo altNachdem ich die Tage Ubuntu neu installiert habe, hadere ich schon wieder damit. Ich bekomme meinen Lieblings-Twitter-Client TweetDeck nicht installiert, weil sich dass dafür benötigte Air-Framework von Adobe unter Unity nicht installieren lässt…

Adobe pflegt Air für Linux bekanntlich nicht mehr, ich habe hier die Installationsdatei der letzten Version. Die hat unter KDE noch einwandfrei funktioniert, und somit konnte ich auch TweetDeck installieren. Auch die letzte Version, die im Air-Framework lief, bevor TweetDeck von Twitter gekauft wurde. Die alte Version unterstützt nämlich auch Identi.ca, nie aktuelle nicht. Zudem läuft die aktuelle Version unter Linux nur als Webapp, z.B. als Chrome-Plugin.

Air meckert bei der Installation das Fehlen des Gnome Keyring oder der KDE-Wallet an, beides Passwortmanager für die entsprechenden Desktopumgebungen. Der Gnome Keyring war jedoch installiert, KDE-Wallet habe ich extra nachinstalliert, und trotzdem wird das Fehlen angemeckert und die Installation von Air bricht mit einer entsprechenden Fehlermeldung an.

Die Suche nach einem gescheiten Client für Twitter und Identi.ca bin ich auf Turpial gestoßen. Den Kommentaren im Ubuntu Software-Center nach soll das wohl der beste Twitter-Client für Linux sein. Allerdings ist das nach einem ersten Test nicht multiaccountfähig, so dass ich mich für einen Account entscheiden müsste…

Damit stehe ich wieder einmal vor der Frage, welchen Twitter-Client ich benutzen soll. Anforderungen: Multiaccount, Mehrspaltenansicht, und vor allem alle Accounts gleichzeitig im Blick, ohne Umschalten oder so. So, wie es TweetDeck macht. Das alte TweetDeck natürlich, wegen Identi.ca…

Also doch Air und TweetDeck

Nachdem ich letztens nach Tipps für einen Twitter-Client gefragt habe, wurde ich mir den angebotenen Programmen nicht glücklich. Das eine stürzt beim Einrichten eines Accounts ab, das andere sogar schon direkt beim Starten… :denk:

TweetDeck-Logo altNachdem ich letztens nach Tipps für einen Twitter-Client gefragt habe, wurde ich mir den angebotenen Programmen nicht glücklich. Das eine stürzt beim Einrichten eines Accounts ab, das andere sogar schon direkt beim Starten… :denk:

Letztlich bin ich doch wieder bei Adobe Air gelandet. Die Linux-Version wird zwar nicht mehr gepflegt und gibt es offiziell nicht mehr zum Download, aber Adobe hat die letzte Linux-Version noch irgendwo in einem Archiv (auch in meiner Dropbox). Und ich war erstaunt, dass Air als 32-Bit-Software sich problemlos auf meinem 64-Bit-Kubuntu installieren ließ.

TweetDeck v0.38.2 (Air-Version)
TweetDeck v0.38.2 (die letzte Air-Version)
Von TweetDeck habe ich die letzte Air-Version noch in der Dropbox, es war also kein Problem, diese zu installieren. Der Rest war dann Formsache: TweetDeck-Account-Daten angeben, und meine Twitter- und identi.ca Accounts waren vorhanden, ebenso meine eingestellten Spalten.

So erfreue ich mich seit ein paar Tagen wieder meinem favorisierten Twitter-Client, der mit die Timeline in Echtzeit durchknallt und mich auf dem Laufenden hält.

Welcher Twitter-Client?

Hallo zusammen, ich hätte da gerne mal ein Problem. Da Adobe Air für Linux nicht weiter entwickelt wird, und sowieso nicht für 64 Bit zur Verfügung steht, suche ich einen neuen Twitter-Client.

Twitter-Logo 2012Hallo zusammen, ich hätte da gerne mal ein Problem. Da Adobe Air für Linux nicht weiter entwickelt wird, und sowieso nicht für 64 Bit zur Verfügung steht, suche ich einen neuen Twitter-Client.

Meinen Lieblings-Client TweetDeck gibt es zudem nicht mehr in der Air-Version, seit das von Twitter aufgekauft wurde. Es gibt nur noch eine native Version für Mac und Windows, die zudem kein identi.ca mehr unterstützt. Nativ für Linux gibt es da als erstes Gwibber (für den Gnome-Desktop) und Choqok (für KDE).

Choqok-LogoGwibber ist scheibar nicht wirklich nutzbar, bleibt also Choqok. Hier fehlt mir die Mehrspaltenansicht aus TweetDeck, um Twitter und Identi.ca nebeneinander darzustellen. Es gibt stattdessen Tabs zum hin- und herschalten. Zudem lief zumindest die Twitter-Timeline in TweedDeck in Echtzeit, der kürzeste Aktualisierungsintervall in Choqok ist ein Minute. Dann kommen 20 neue Tweets auf einmal, und es muss gescrollt werden.

Daneben habe ich hier Trupial. Das kann zwar mehrere Spalten und kommt auch mit Identi.ca zurecht, aber nicht gleichzeitig. Das Tool scheint nicht multiaccountfähig zu sein.

Daher mal eine Frage an Euch, liebe Leser: Könnt ihr mir einen Twitter- und Identi.ca-Client empfehlen, der nativ unter Linux läuft, mehrere Spalten anzeigen kann und multiaccountfähig ist? Für ein gutes Stück Software bin ich auch gerne bereit, ein paar Euro zu zahlen.

Adobe Air auf einem 64bit Linux

Adobe Air ist ein Framework, welches die Ausführungs-Umgebung für einige schicke Programme stellt. So auch für meinen Lieblings-Twitterclient „TweetDeck”. Das Problem: Air gibt es nur für 32bit-Systeme, zumindest unter Linux. Ich habe hier aber ein 64bit Kubuntu laufen
Nun habe ich direkt bei Adobe eine (englische) Anleitung gefunden, wie man das 32bit Air auf einem 64bit Linux installiert. Ich gebe das jetzt mal nicht komplett wieder, sondern verweise nur auf die Adobe-Seite.

Adobe Air LogoAdobe Air ist ein Framework, welches die Ausführungs-Umgebung für einige schicke Programme stellt. So auch für meinen Lieblings-Twitterclient „TweetDeck”. Das Problem: Air gibt es nur für 32bit-Systeme, zumindest unter Linux. Ich habe hier aber ein 64bit Kubuntu laufen

Nun habe ich direkt bei Adobe eine (englische) Anleitung gefunden, wie man das 32bit Air auf einem 64bit Linux installiert

Install AIR 2 on 64-bit Ubuntu 9.04

  1. To install 32-bit libraries on Ubuntu, make sure that you have a utility called getlibs. You can download the getlibs utility from http://frozenfox.freehostia.com/cappy/getlibs-all.deb or http://taurinocerveza.com/scripts/getlibs-all.deb. Install the package as:
    $ sudo dpkg -i getlibs-all.deb
  2. Download the 32-bit dependencies of AIR using the following commands:
    $ sudo ./AdobeAIRInstaller.bin
    $ sudo getlibs -l libhal-storage.so.1
    $ sudo getlibs -l libgnome-keyring.so.0.1.1
  3. Download the 32-bit versions of libnss and libnspr from the following locations:

    http://mirrors.kernel.org/ubuntu/pool/main/n/nss/libnss3-1d_3.12.3.1-0ubuntu2_i386.deb
    http://mirrors.kernel.org/ubuntu/pool/main/n/nspr/libnspr4-0d-dbg_4.7.1~beta2-0ubuntu1_i386.deb

  4. Open the packages you downloaded by running file-roller as root so that you can extract them to your /usr/lib32 folder. Begin by extracting the files in libnss, using the following command:
    $ sudo file-roller libnss3-1d_3.12.3.1-0ubuntu0.9.04.2_i386.deb

    Double-click the data.tar.gz file. If the data.tar.gz file doesn’t open automatically in file-roller, you are asked which application to open it with. If prompted to choose the application, enter file-roller in the Application box and click Open.

    In file-roller, locate and select the following files in the ./usr/lib folder:

    libnss3.so.1d
    libnssutil3.so.1d
    libsmime3.so.1d
    libssl3.so.1d

    Click Extract. Click the upper-left button in this window (the image of a pencil and paper). If you hover your mouse over the button, it displays „Type a file name“ in tool tip. After you click the button, a Location box appears. Type /usr/lib32 in the location box and click Extract.

    Close all file-roller windows.

  5. Extract the files in libnspr package using the following command:
    $ sudo file-roller libnspr4-0d_4.7.5-0ubuntu0.9.04.1_i386.deb

    Double-click the data.tar.gz file and open with file-roller. Then locate and select the following files in the ./usr/lib folder:

    libnspr4.so.0d
    libplc4.so.0d
    libplds4.so.0

    Follow the same instructions as above (in Step 4) to extract the files to the /usr/lib32 folder.

  6. Create the following soft links:
    $ sudo ln -s /usr/lib32/libnss3.so.1d /usr/lib32/libnss3.so
    $ sudo ln -s /usr/lib32/libssl3.so.1d /usr/lib32/libssl3.so
    $ sudo ln -s /usr/lib32/libnspr4.so.0d /usr/lib32/libnspr4.so
  7. Run the Adobe AIR 2 installer:
    $ ./AdobeAIRIntaller.bin
  8. Because of the absence of the lib32nss package, AIR apps can’t connect to the network. Ubuntu 9.04 64-bit users require the package lib32nss-mdns for DNS resolution in a 32-bit application:
    $ sudo apt-get install lib32nss-mdns

    Note: If you are installing the runtime using debian package, use the following command:

    $ sudo dpkg -i --force-architecture <adobe_air_package_name>

    Die Anleitung ist für Ubuntu, daher wird die Gnome-Anwendung „file-roller” gefordert. Diese ist ggf. auf Kubuntu schnell nachinstalliert, oder man bedient sich eines KDE-eigenen Archiv-Managers wir z.B. Ark.

    Während der Installation werden jedoch mehrere Gnome-Bibliotheken installiert, aber einige andere GTK-basierte Programme wie Firefox oder Gimp brauchen die auch.

    Wichtig ist, dass ich Adobe Air installiert bekommen habe. In der aktuellen Version

    Noch mehr Twitter

    Ich bin heute bei Robert auf einen schicken Twitter-Client gestolpert, der die Informationen in mehreren Spalten anzeigt: „TweetDeck”.

    Ich bin heute bei Robert auf einen schicken Twitter-Client gestolpert, der die Informationen in mehreren Spalten anzeigt: „TweetDeck”. In der Linken Spalte der Beta-Software wird die ganz normale Timeline angezeigt, wie in jedem anderen Client auch. Daneben gibt’s ’ne Spalte für die Replies, was auch nicht schlecht ist. Rechts davon kann man sich dann Gruppen aus seinen Followern zusammenstellen, um z.B. Diskussionen zusammenzufassen, oder alle Friends, die z.B. über SEO zwitschern, in eine Gruppe zu packen.

    TweetDeck
    Der TweetDeck Twitter-Client ist noch im Beta-Stadium

    Des Weiteren schwärmen einige meiner Friends seit längerem für „Twhirl”. Den habe ich vor ein paar Stunden zu meinem Favoriten erklärt. TwhirlDenn der lässt sich als einziger auf eine deutschsprachige GUI umschalten, kann mehrere Twitter Accounts verwalten und versteht sich sogar mit FriendFeed. Dazu kommt, dass ich die gesamte Friend- und Follower-Verwaltung direkt im Client machen kann, ohne erst die Twitter-Homepage aufzurufen. Sogar die Suche nach neuen Friends ist direkt in „Twhirl” möglich.

    Twhirl
    Der Twhirl Twitter-Client im Farbschema „Black Magic”
    Beide hier vorgestellten Clients setzen auf das AIR-Framework von Adobe auf, allerdings haben beide keine Probleme mit den Umlauten. Das Problem hatte ich gestern ja noch auf AIR geschoben, weil da andere darauf basierende Clients Probleme haben.

    „TweetDeck” habe ich nicht weiter getestet, aber entgegen der Aussage auf der Website läuft das auch unter Linux. Ebenso wie „Twhirl”, das laut Website nur auf WinDOSen und Mac-Systemen laufen soll. Diese Aussagen beruhen aber wohl darauf, dass es für Linux noch keine offizielle AIR-Version gibt, sondern nur eine Alpha.

    „Twhirl” kommt per Default im türkisen Twitter-Look daher, lässt sich aber über Color Shemes auch umfärben. So ein schickes Schwarz, das habe ich mir ausgesucht. Und „Twhirl“” informiert nicht nur mit einem Popup in der Bildschirm-Ecke über neue Tweets, sondern auch mit einem dezenten akustischen Signal. Sehr schön.

    Zwitschern mit Spaz

    Spaz-IconIch hatte schon mal über den Twitter-Client Spaz gebloggt, für den ich mich entschieden habe. Aber so ganz optimal ist das zumindest für Linuxer wirklich noch nicht. Das kann aber auch an der Runtime AIR von Adobe liegen, die für Linux noch Alpha-Status hat.

    So speichert Spatz z.B. die Twitter-Zugangsdaten nicht, die müssen bei jedem Programmstart neu eingegeben werden. Wenn ich mir Snitter ansehe, ein ebenfalls auf AIR setzender Twitter-Client, der kann das speichern. Der Fehler liegt also eindeutig an Spaz.

    Ein weiterer Fehler ist die Verarbeitung der deutschen Umlaute. Spaz kann die zwar anzeigen, wenn jemand die mitsendet, aber ich kann die nicht oder nur zum Teil eingeben. Aktuell geht das „Ä“ und das „ß“, die Tasten für „Ö“ und „Ü“ sind tot. Das liegt aber scheinbar an AIR, den auch in Snitter geht das nicht…

    Gestern habe ich Spaz auf die aktuelle Version 4.0.0 aktualisiert, jetzt sind zumindest die Eingabefelder für Username und Passwort in den Optionen sauber platziert. Vorher waren die fast ineinander verschachtelt.

    Was AIR angeht, da muss ich mal weiter auf aktuelle Versionen warten, die dann nach Möglichkeit mindestens Beta sind. Am Besten allerdings ein Final Release Denn ich muss feststellen, dass AIR-Apps zumindest hier auf meiner Sidux-Kiste Ressourcenfresser sind.

    Linuxtauglicher Twitter-Client

    TwitterJa, genau sowas suche ich. Ich hatte den Twitter in der Sidebar des Firefox, aber dieses Addon ist mit FX3 nicht kompatibel. Da habe ich dann TwitterFox eingesetzt. Machte mich aber auch nicht wirklich glücklich. :roll:

    Ich habe dann mal Tante Gurgel bemüht, und habe da die ein oder andere Desktop-Software gefunden, die auch zum Teil schon in den Debian- und Sidux-Repos vorhanden waren. Davon konnte mich aber auch nichts wirklich überzeugen, das meiste lief sogar gar nicht erst. :evil:

    Ich stieß dann noch auf Spaz, ein Multi-Plattform-Client für Twitter. Das Problem: Spaz benötigt das noch recht neue AIR-Framework von Adobe®, und das gibt es für den Mac und die WinDOSe, aber eben nicht für Linux. Dies zumindest suggeriert die Zielseite des AIR-Links auf der Spaz-Downloadseite

    Mal davon abgesehen, dass mir Adobe®-Software nicht wirklich in den Kram passt (Closed Source), man weiß doch gar nicht so recht, was AIR überhaupt macht und kann. Zumindest ich habe mich damit bisher noch nicht beschäftigt. Aber ich habe mich wieder in die unendlichen Weiten des Internets begeben und bin bei Adobe® Labs auf eine Linux-Version von AIR gestoßen. Das ist allerdings noch eine Alpha-Version, die dazu noch nicht alle AIR-Funktionen unterstützt. O.o

    Nun denn, ich habe das mal geladen, kommt als .bin-Datei, die dann ausführbar gemacht werden muss:

    chmod +x adobeair_linux_a1_033108.bin

    „Linuxtauglicher Twitter-Client“ weiterlesen